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Chapter 1 – Introduction

Introduction to CAD

Computer Aided Design (CAD) is the application of computers for the purpose of design and
drafting of engineering or non-engineering systems. Sometimes CAD is also referred as
Computer Aided Design and Drafting (CADD). CAD is a process of creating or modifying the
technical drawings, layouts, 3D models etc. using computers. The output of CAD software is in
electronic format in the form of computer files. CAD Software uses either Vector based
approach or Raster based approach to create the drawings. Apart from the shape and size, the
CAD drawings also provide information on materials, processes, specifications, special
instructions, indications etc.

Now-a-days, CAD is an important application widely used in Mechanical, Civil, Architectural,
Aerospace, Chemical, Electrical, Railways, Ship Building, technical documentation, animations,
renderings and many more fields. The manual drafting methods are almost obsolete due the
advantages of CAD software tools.

Initial developments on CAD were carried out in the 1960s within the aircraft and automotive
industries in the area of 3D surface construction and NC programming. Some of the
mathematical description work on curves was developed in the early 1940s by Robert Issac.
However, probably the most important work on polynomial curves and sculptured surface was
done by Pierre Bézier (Renault), Paul de Casteljau (Citroen), Steven Anson Coons (MIT, Ford),
James Ferguson (Boeing), Carl de Boor (GM), Birkhoff (GM) and Garibedian (GM) in the 1960s
and W. Gordon (GM) and R. Riesenfeld in the 1970s.

Advantages of CAD Drawings

 Faster to create and modify the drawings.
 More accurate to draw and measure compared to manual drawings.
 Saving copies is much easier and effort will be less to create replicates.
 Easy to share the drawings in electronic format with others.
 Space requirement is less in design office as there is no need of bigger drafting

machines.
 CAD software is inexpensive and there are few free versions too.
 Drawings look more professional in terms of line widths, text, fonts etc.
 Facilitate the file management using database.
 Computer files never lost or deteriorate unlike manual paper or sepia drawings.
 Standard functions and commands help to create special geometries much faster.
 Zooming can be done easily for enlarged or reduced view scale.
 Changing the Scale is very simple for the whole drawing, model or views.
 Drafting skill requirement is less in CAD.
 Repetitive tasks can be automated in the form of LISP, VBA, ARX programs.
 Standard elements like Title blocks, symbols (civil, mechanical, electrical, electronics,

architectural etc) can be stored in the form of templates, blocks etc.
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 Symbols and source files can be downloaded from internet without the need of
developing them from scratch.

 Integration is possible from other computer documents like Excel, Word, PDF, JPEG,
GIF etc.

 Easy to handle drawings as CAD software supports Layer concept. Unwanted elements
in layers can be switched-off when not needed. This is not possible on manual drawings.

Popular CAD Softares and Developers

CAD Software Developer
Unigraphics NX Siemens Industry Software

I-DEAS Siemens Industry Software
CATIA Dassault Systemes

Solid Edge ST Siemens Industry Software
Solid Woks Dassault Systemes

Creo Elements PTC
AutoCAD AutoDesk
ActCAD ActCAD.LLC

What is IntelliCAD?

The IntelliCAD Technology Consortium (ITC) is an organization owned and governed by its
members. ITC focuses on the development of the IntelliCAD CAD platform compatible with the
DWG file format. ITC members focus on the customization, marketing and sales of CAD
solutions based on the IntelliCAD technology. ITC Commercial Members have unlimited
distribution rights for delivering the IntelliCAD technology to their customers.

The ITC is a non-profit organization and invests over 70% of revenue back to research and
development. The ITC developers are seasoned programmers having expertise in 2D and
3D math and visualization.

About ActCAD:

ActCAD is a 2D Drafting and 3D Modeling CAD software meant for Engineers, Architects and
other technical consultants. ActCAD is a native DWG & DXF CAD software to create and edit
drawings. ActCAD is based on the technologies from IntelliCAD Technology Consortium (ITC),
ODA Teigha Libraries, ACIS 3D Kernel, Wintopo, ps2edit etc. ActCAD uses the most recently
released version of IntelliCAD to offer the best performance and features to its users. ActCAD
as many add-on commands and features supplementing core IntelliCAD making ActCAD more
productive than its competition. In addition, ActCAD includes many other tools like Block
Libraries (in the domains of Civil, Mechanical, Electrical, Architectural, Structural, P &IDs etc.),
Batch file converter, Units converter and many other productivity enhancement tools.

ActCAD can open the .dgn file formats and saving them to dwg/dxf file formats. All dwg/dxf
versions from R2.5 to 2018 are supported...
ActCAD is a light weight yet very powerful Professional Computer Aided Design (CAD) software
utilizing the benefits of multi-threading and multi-core processing capabilities of recent computer
systems. The technology is being enhanced by well experienced Developers working from all
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over the World, around the clock. The core developers of ActCAD have over 40 years of
experience in industry especially on CAD software. There are many other tools available in the
markets which do not have an optimum balance between capability and price. Some of the
capable tools are very expensive and on the other hand, some of the low cost tools are not
capable of handling critical project requirements. ActCAD perfectly bridges this price
performance gap offering great value to our customers.

Advantages of ActCAD

 Very Low Price : With Full Features & Functions

 No Special Learning : Familiar interface, commands & Icons

 Best Performance : True power of 64bit & Multi-threading

 Perpetual Licenses : Global Validity & Self-License Transfer

 ActCAD Converter : Batch Auditing & File Conversions

 All DWG & DXF versions : From R2 to 2018

 PDF Export : Both 3D PDF & 2D PDF Export

 Dr.KLN Drawings Converter : PDF/PS to DXF/SVG/PCG Conversion

 Raster to Vector : Image/Scanned Drawings to DXF Conversion

 Express Tools & Add-on Features

 Content Management : Over 5000 Blocks included. Add your own too.

 Many Featuers & Improvements in addition to IntelliCAD 8.4b Engine.
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Chapter 2: Interface Study & Menus

Starting up ActCAD

Select the ActCAD option on the program menu or select the ActCAD icon on the desktop.
Once the program is loaded into memory, the ActCAD drawing screen will appear on the screen.

Note that ActCAD automatically assigns generic names, Drawing X, as new
drawings are created. In our example, ActCAD opened the graphics window using the default
system units and assigned the drawing name Drawing1.

ActCAD Interface

A:Menu Bar D:UCS(User Co-ordinate System) G:Status Bar

B:Toolbars E:Properties Window H:Floating or Docking ToolBar

C:Graphics Window F:Command Bar I:Cross Hair

D

E

F

I

C

B

A

H

G
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A: Menu bar can be customized at the top of the window

B: Toolbars can be customized by changing the appearance and arrangement of tools
and adding required commands and macros.

C: Drawing window displays the drawings Created. It is the working area for the
drawings to be created.

D: The user coordinate system (UCS) icon indicates the orientation of the drawing in
three-dimensional space. It can be taken as reference point from which the cursor
location Co-ordinates will be displayed in the Status bar

E: Layout bar contains one model and two layouts will be available which can be
increased to a maximum of 256 layouts, Click a tab to switch between the drawing
model and a print layout

F: Command bar is used to give the inputs to the drawing through typed commands. To
reposition the command bar, drag it to another location on the screen.

G: The status bar displays information such as the name or purpose of a tool, the current
cursor coordinates, layer name, and mode settings.

H: Floting or docking Toolbars-toolbars can be moved and docked at any location on the
screen as desired.

I: The Cross Hair displays the cursor location and the orientation of X, Y axis of drawing.

Tool Tips

ToolTips To find out what a specific tool on a toolbar does, pause the cursor over it for a
moment. A ToolTip appears on the screen. with its name

Tool Tips

Drawing Units Setup

Every object we construct in a CAD system is measured in units. We should determine
the value of the units within the CAD system before creating the first geometric entities.

1. In the pull-down menus, select:[Format] [Units]

2. In the Drawing Units dialog box, set the Length Type to Decimal. This will set the
measurement to the default Metric Units.
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3. Set the Precision to two digits after the decimal point as shown in the above
figure.

4. Pick OK to exit the Drawing Units dialog box.

Drawing Area Setup

Next, we will set up the Drawing Limits; setting the Drawing Limits controls the extents of
the display of the grid. It also serves as a visual reference that marks the working area. It can
also be used to prevent construction outside the grid limits and as a plot option that defines an
area to be plotted/printed. Note that this setting does not limit the region for geometry
construction.
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1. In the pull-down menus, select: [Format] [Drawing Limits]

2. In the command prompt area, near the bottom of the proge CAD drawing screen,the
message “Reset Model Space Limits: Specify lower left corner or [On/Off]<0.00,0.00>:”
is displayed. Press the Enter key once to accept the default coordinates <0.00,0.00>.

3. In the command prompt area, the message “Specify upper right corner <0.00,0.00>:” is
displayed. Press the ENTER key once to accept the default coordinates <12.00,9.00>.

4. On your own, move the graphic cursor near the upper-right comer inside the drawing
area and note that the drawing area is unchanged. (The Drawing Limits command is
used to set the drawing area; but the display will not be adjusted until a display
command is used.)

5. Move the graphic cursor near the upper right comer inside the drawing area and note
that the display area is updated.

GRID - ON/OFF:

1. Left-click the GRID button in the Status Bar to turn ON the GRID option. (Notice in the
command prompt area, the message “<Grid on>” is also displayed.)

2. Right-click on GRID button in the Status Bar to change setting of GRID like Grid spacing
and Grid angel.
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SNAP - ON/OFF:

1. Left-click the SNAP button in the Status Bar to turn ON the SNAP option.

2. Right-click on SNAP button in status bar to change settings for snap distance.

ORTHO:

ActCAD provides drawing and editing tools similar to the drafter's T-square. As you
create or move objects, you can use Ortho mode to restrict the cursor to the horizontal or
vertical axis. The orthogonal alignment depends on the current snap angle, UCS, or isometric
grid and snap setting. Ortho works with commands that require you to specify a second point.
You can turn Ortho on and off at any time during drawing and editing. You can use Ortho not
only to establish vertical or horizontal alignments but also to enforce parallelism or to create
regular offsets from existing objects.

By imposing orthogonal constraints, you can draw more quickly. For example, you can
create a series of perpendicular lines by turning on Ortho mode before you start. Because the
lines are constrained to be parallel to the horizontal and vertical axes, you know that the lines
are perpendicular.

As you move the cursor, a rubber-band line that defines the displacement follows the
horizontal or vertical axis, depending on which axis is nearest to the cursor. ActCAD overrides
Ortho when you enter coordinates on the command line, use perspective views, or specify an
object snap.
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To turn on or turn off Ortho mode

 On the status bar, click Ortho.

POLAR TRACKING:

Polar tracking restricts cursor movement to specified angles. Polar Snap restricts cursor
movement to specified increments along a polar angle.

When you are creating or modifying objects, you can use polar tracking to display
temporary alignment paths defined by the polar angles you specify. In 3D views, polar tracking
additionally provides an alignment path in the up and down directions. In that case, the tooltip
displays a +Z or -Z for the angle.

Polar angles are relative to the orientation of the current user coordinate system (UCS)
and the setting for the base angle convention in a drawing. The angle base direction is set in the
Drawing Units dialog box (UNITS).

To turn on and turn off polar tracking
1. Press F10, or click the polar button on the status bar.
2. To turn polar tracking on or off temporarily, hold down the F10 key while you work.

Note Turning on Ortho automatically turns off polar tracking.

ESNAP:

The Entity Snaps (Esnaps for shlort) are drawing aids which are used in conjunction with
other commands to help you draw accurately. Esnaps allow you to snap onto a specific object
location when you are picking a point. For example, using Esnaps you can accurately pick the
end point of a line or the center of a circle. Esnaps in ActCAD are so important that you cannot
draw accurately without them. For this reason, you must develop a good understanding of what
the Esnaps are and how they work.

There are three basic methods of accessing the Esnaps:

1. The Esnaps are also available on their own Object Snap toolbar. If this toolbar is not
already displayed, you can display it using the TOOLBAR command, View Toolbars…
from the pull-down menu. When the Toolbar dialogue box appears, simply check the box
next to "Object Snap" in the toolbars list. Many ActCAD users work with the Object Snap
toolbar permanently docked on their screen because it gives one-click access to all of
the Esnaps, making drawing much more efficient.
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2. You can also access the Esnaps from the cursor menu. Hold the Shift key down on the
keyboard and right-click the mouse to bring up the cursor menu. The menu appears at
the current cursor position.

3. Finally, you can also access the Esnaps from the keyboard by typing their abbreviated
name. See the exercise above and the sections below for details.

Endpoint :

Toolbar Object Snap

Pull-down Shift + Right Click Endpoint

Keyboard END (when picking)

The Endpoint Esnap snaps to the end points of lines and arcs and to polyline vertices.
This is one of the most useful and commonly used Esnaps.

Midpoint :

Toolbar Object Snap

Pull-down Shift + Right Click Midpoint

Keyboard MID (when picking)

The Midpoint Esnap snaps to the mid points of lines and arcs and to the mid point of
polyline segments.

Intersection :

Toolbar Object Snap

Pull-down Shift + Right Click Intersection

Keyboard INT (when picking)

The Intersection Esnap snaps to the physical intersection of any two drawing objects

Extension :

Toolbar Object Snap

Pull-down Shift + Right Click Extension
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Keyboard EXT or EXTEN (when picking)

The Extension Esnap enables you to snap to some point along the imaginary extension of a line,
arc or polyline segment.

Center :

Toolbar Object Snap

Pull-down Shift + Right Click Center

Keyboard CEN (when picking)

The Center Osnap snaps to the centre of a circle, arc or polyline arc segment. The cursor must
pass over the circumference of the circle or the arc so that the centre can be found.

Quadrant

Toolbar Object Snap

Pull-down Shift + Right Click Quadrant

Keyboard QUA or QUAD (when picking)

The Quadrant Osnap snaps to one of the four circle quadrant points located at north, south,
east and west or 90, 270, 0 and 180 degrees respectively.

Tangent :

Toolbar Object Snap

Pull-down Shift + Right Click Tangent

Keyboard TAN (when picking)

The Tangent Osnap snaps to a tangent point on a circle. This osnap works in two ways. You
can either draw a line from a point to the tangent point (see illustration) or you can draw a line
from a tangent point, the latter is referred to as the
"Deferred Tangent" snap mode.

Perpendicular :

Toolbar Object Snap

Pull-down Shift + Right Click Perpendicular

Keyboard PER or PERP (when picking)
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The Perpendicular Osnap snaps to a point which forms a perpendicular with the selected
object. As with the Tangent Osnap, Perpendicular can be used to draw a line to a perpendicular
point, as in the illustration or from a perpendicular point, known as the "Deferred Perpendicular"
snap mode.

parallel. You can now pick the second point of your line. The Snap Tip also includes a
relative polar co-ordinate.

Insert :

Toolbar Object Snap

Pull-down Shift + Right Click Insert

Keyboard INS (when picking)

The Insert Osnap snaps to the insertion point of a block, text or an image.

Node

Toolbar Object Snap

Pull-down Shift + Right Click Node

Keyboard NODE (when picking)

The Node Osnap snaps to the center of a Point object. This osnap can be useful if you
have created a number of Points with the Measure or Divide commands. You could, for example
insert a number of regularly spaced tree symbols (blocks) along a line by using the Node Osnap
for the insertion point of each block

ETRACK :

Use object snap tracking to track along alignment paths that are based on object snap
points. Acquired points display a small plus sign (+), and you can acquire up to seven tracking
points at a time. After you acquire a point, horizontal, vertical, or polar alignment paths relative
to the point are displayed as you move the cursor over their drawing paths. For example, you
can select a point along a path based on an object endpoint or midpoint or an intersection
between objects.
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LWT :

Lineweights can be turned on and off in a drawing, and are displayed differently in model space
than in a paper space layout.

In model space, a 0-value lineweight is displayed as one pixel, and other lineweights use a pixel
width proportional to their real-unit value.

In a paper space layout, lineweights are displayed in the exact plotting width.

Regeneration time increases with lineweights that are represented by more than one pixel. Turn
off the display of lineweights to optimize performance of the program.

You can turn the display of lineweights on or off by clicking LWT on the status bar. This setting
does not affect the plotting of lineweights.

MODEL:

In ActCAD you can switch between model and layout by using model button provided in status
bar.

CAD FILE DATA STRUCTURE:

Designs and drawings created in a CAD system are usually defined and stored using sets of
points in what is called world space. In most CAD systems, the world space is defined using a
three-dimensional Cartesian coordinate system. Three mutually perpendicular axes, usually
referred to as the X, Y, and Z-axes, define this system. The intersection of the three coordinate
axes forms a point called the origin. Any point in world space can then be defined as the
distance from the origin in the X, Y and Z directions. In most CAD systems, the directions of the
arrows shown on the axes identify the positive sides of the Coordinates.

A CAD file, which is the electronic version of the design, contains data that describe the
entities created in the CAD system. Information such as the coordinate values in world space for
all endpoints, center points, etc., along with the descriptions of the types of entities is all stored
in the file. Knowing that ActCAD stores designs by keeping coordinate data helps us understand
the inputs required to create entities.
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USER COORDINATE SYSTEM (UCS):

The icon near the bottom left corner of the default ActCAD Graphics window shows the
positive X-direction and positive Y-direction of the coordinate system that is active. In ActCAD,
the coordinate system that is used to create entities is called the User Coordinate System
(UCS). By default, the User Coordinate System is aligned to the world coordinate system (WCS).
The world coordinate system is a coordinate system used by ActCAD as the basis for defining
all objects and other coordinate systems defined by the users. We can think of the origin of the
world coordinate system as a fixed point being used as a reference for all measurements. The
default orientation of the Z-axis can be considered as positive values in front of the monitor and
negative values inside the monitor.

SHOWING AND HIDING TOOLBARS:

Display a toolbar with one of the following methods

1. Right-click any toolbar and click a toolbar on the shortcut menu.

2. Click Tools Toolbars and click the toolbar to display.
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KEYBOARD SHORTCUT KEYS:

Shortcutkeys are key combinations that start commands. For example, you can press
Ctrl+O to open a file and Ctrl+S to save a file, which is the same as clicking Open and Save on
the Toolbar or File menu.

CREATING ANDMANAGING ALIASES:

A command alias is an abbreviation that you enter at the command prompt instead of entering
the entire command name.

For example, you can enter c instead of circle to start the CIRCLE command. An alias is
not the same as a keyboard shortcut, which is a combination of keystrokes, such as CTRL+S
for SAVE.

To Create Aliases:

 Select Customize option from tools menu,

 Select menu customize, then you will get a dialog box namely Customize,

 In that dialog box select aliases tab to create or assign aliases to
commands which are available in ActCAD

 In that dialog box you can import and export the aliases
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PROMPT BOXES:

ActCAD commands often provide several options. These options appear in the status
bar or command bar and also in a prompt box (called a context menu in Autodesk AutoCAD)
initially displayed in the upper right corner of the screen. You can move the prompt box by
dragging it; future prompt boxes will appear where you last placed it. The options appear as
menu selections. Choose the appropriate option by selecting it in the prompt box. To close a
prompt box, click the Close box.

The prompt box isn’t displayed by default. To turn on the display of prompt boxes, choose Tools
> Options, click the Display tab, and then click the Display Prompt Boxes check box.

MOUSE SHORTCUTS:

You can use your mouse, often combined with the keyboard, to start commands and
perform other actions. The list of mouse shortcuts given below:

Mouse Shortcut Action

Ctrl + Shift + Hold and drag left mouse button Real-Time Zoom command

Ctrl + Shift + Hold and drag right mouse
button

Real-Time Pan command

Ctrl + Hold and drag left mouse button Real-Time Sphere command
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UNDO:

ActCAD tracks the commands you use and the changes you make. If you change your
mind or make a mistake, you can undo, or reverse, the last action or several previous actions.

Toolbar: Standard Command: undo shortcut: ctrl+z

REDO:

To reverse the effect of previous undo commands.

Toolbar: Standard Command: redo shortcut: ctrl+y

PURGE:

Do one of the following to get purge dialog box:

•Choose File > Utility > Purge.

•Type purge and then press Enter.

Ctrl + Hold and drag right mouse button Real-Time Z command

Shift + Left-click mouse Deselect entities

Shift + Right-click mouse Entity snap shortcut menu

Hold and drag left mouse button Move selected entities

Ctrl + Hold and drag left mouse button Copy and move selected
entities

Right-click mouse Display shortcut menu for the
selected entity

Rotate mouse wheel Zoom In and Zoom Out
commands

Hold mouse wheel, and then move mouse Pan command
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Using the option buttons above the Items List window, you choose if you want to display
the items that you can purge (items not used) or if you want to display those that you cannot
purge. In the Item List area you can view the items that can be purged divided into categories.
The plus symbol next to group names indicates that there are objects you can purge.Linetypes
definitions are purged only from the current drawing, the definition in the file icad.lin remains
unchanged. If you mark the check box Confirm each item to be purged, you will be asked to
confirm before purging the items.

 Purge nested items: removes all the unused named objects from the drawing even if
they are contained within or referenced by other unused named objects. The Confirm
Purge dialog box is displayed and you can cancel or confirm the items to be purged.

 Nested Blocks: for example, you create a block from a circle and insert two instances
of this block in the drawing. Next, you create a new block that consists of two previous
circle blocks: in this way you will have a nested block in your drawing. Marking the check
box Purge nested items you can purge in one session even nested blocks. It is
recommended to leave active the position Confirm each item to be purged in order to be
able to verify the blocks to be purged.

 Purge: purges the selected items.

 Purge all: purges all the unused items.

ISOMETRIC SNAPPING :

You can use the Isometric Snap option to create two-dimensional isometric drawings.
With the isometric option, you are simply drawing a simulated three-dimensional view on a two-

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

29

dimensional plane, much the same as you might draw on a piece of paper. Do not confuse
isometric drawings with three-dimensional drawings. You create three-dimensional drawings in
three-dimensional spaceThe isometric option always uses three preset planes, which are
denoted as left, right, and top. You cannot alter the arrangement of these planes. If the snap
angle is 0, the three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you check the Isometric Snap option and select an isometric plane, the snap intervals,
grid, and crosshairs align with the current plane. The grid is always shown as isometric and
uses y-coordinates to calculate the grid spacing. If you click the Draw Orthogonal check box, the
program restricts the drawing of entities to the current isometric planes.

 To toggle between isometric planes, press F5

To turn the Isometric Snap:
1. Do one of the following:

 Choose Tools > Drawing Settings.

 Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, select Snap And Grid.

4. Click the Isometric Snap And Grid check box.

5. Under Isometric Crosshairs, click the option for the isometric plane you want
(Top, Left, or Right).

6. Click OK.

Isometric planes left (A), right (B), top (C).

ALIGNMENT:

When you create paragraph text, you can set the text alignment by specifying the
attachment point location in relation to the paragraph text boundary and the direction in which
text flows within the boundary. You can set the paragraph text alignment either in the prompt
box displayed after you specify the first corner of the paragraph text boundary or from the
Multiline Text dialog box. You can specify the attachment point at the top left, top center, top
right, middle left, middle center, middle right, bottom left, bottom center, or bottom right. The
paragraph text can flow left to right, right to left, top to bottom, or bottom to top.
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CURSOR COORDINATE VALUES:

When your cursor rolling over Graphics window the location of your cursor will be shown
on status bar, these values will be shown respective of your cursor location from UCS.

SCROLL BARS:

To show or hide the scroll bars that display on the right side and bottom of the ActCAD
window or viewport, select the Show Scroll Bars check box. You may want to hide the scroll
bars if you only use the Pan command to scroll drawings

SCROLL BARS

COMMAND BAR:

The command bar is a dock able window in which you type ActCAD commands and
view prompts and other program messages. To display the command bar, choose View >
Display > Command Bar. When initially displayed, the command bar is docked between the
toolbars and the drawing. It displays the three most recent lines of prompts. You can move the
command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to
change the number of lines of text it displays. You can dock the command bar at the top or
bottom of the drawing.
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SELECTIONWINDOW OPTIONS:

When you choose a command that requires you to select entities (when you’re deleting or
changing entity properties, for example), you can use any of the following selection methods by
choosing them in the prompt box or entering them in the command bar:

1. Window selection

2. Crossing selection

Window selection:
 Click to select a point in the drawing.

 Click to the right of the first point to select a second point in the drawing.

Crossing selection:

 Click to select a point in the drawing.

 Click to the left of the first point to select a second point in the drawing.

CALCULATOR:

ActCAD enables you a calculator to make calculations much fast simply type CAL in
command window and press enter then you will get a windows calculator
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Chapter 3: Standard Commands

DRAWING TEMPLATES:

 A drawing template file is used to provide consistency in the drawings that you create
by providing standard styles and settings.

 Drawing template files have a .dwt file extension.

 When you create a new drawing based on an existing drawing template file and make
changes, the changes in the new drawing do not affect the drawing template file.

A default set of drawing template (DWT) files is installed with ActCAD which are used to create
2D drawings and 3D models. Many of the default drawing templates are offered in two measurement
types: imperial and metric. When using one of the default drawing templates you need determine if you
will be working in 2D or 3D, and which measurement type best describes your work.

While the default templates provide for a quick way to start creating a new drawing, it is best to
create drawing templates specific to your company and the drawings you create. You can use Initial
Setup to select a drawing template that is close to your requirements, but you will still need to do some
work to make the drawing template file work best for you.

CREATING A NEW TEMPLATE:

When you need to create several drawings that use the same conventions and default settings, you
can save time by creating or customizing a drawing template file instead of specifying the conventions
and default settings each time you start. Conventions and settings commonly stored in template files
include

 Unit type and precision

 Title blocks, borders, and logos
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 Layer names

 Snap, Grid, and Ortho settings

 Grid limits

 Annotation styles (dimension, text, table and multileader)

 Line types

By default, drawing template files are stored in the template folder, where they are easily accessible.

CREATE A NEW FILE:

Command NEW: Creates a new drawing. ActCAD opens a START dialog box, in which you can select
the Default settings like Unit system of your drawing either Metric or English. And you can use required
templates

Menu: File » New Keyboard: NEW Shortcut key: N

OPEN FILE:
You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web Format™

(.dwf) files, and drawing template (.dwt) files.

You can also open and check drawings that you suspect are damaged.

Opening an existing drawing
You can open any of these drawing files:

 Standard drawing files with a .dwg extension.

 In addition to your own drawing files, you can open and use one of the sample drawings
that are included with ActCAD.
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 Drawing Exchange Format files with a .dxf file extension.

 Design Web Format files with a .dwf file extension.

 Drawing templates with a .dwt file extension.

To open an existing drawing

1. Use one of the following methods:

 Choose File > Open.

 On the Standard toolbar, click the Open tool ( ).

 Type open and then press Enter.

2. In Files of Type, choose the type of file you want to open.

3. Choose the folder containing the desired file.

4. Do one of the following:

 Choose the drawing you want to open and then click Open.

 Double-click the drawing you want to open.

CLOSE FILE:
Menu: File » Close Keyboard: CLOSE

Closes the current drawing file.

Before executing CLOSE command, if the current drawing file is not saved after modification, the
system will prompt the user whether to save or not.If current drawing file is unchanged or want to
cancel modification, you can close the file directly.
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SAVE FILE:
Keyboard: SAVE Aliases: SA Shortcut key: CTRL+S

Saves the current drawing under the current file name. The system displays the Save Drawing As
dialog box, in which you can save the file with a new name or an existing name. The command line
shows as follows:

File name (extension defines export type) <current path>: Enter a file name and extension or
press ENTER

SAVE AS:
Menu: File » Save as Keyboard: SAVE AS Shortcut key: CTRL+SHIFT+S

Saves the current drawing under another name or another format. The system displays Save Drawing As
dialog box, in which you can specify a new name and format to save the current drawing.

The prompts on the command line are as follows: File name (extension defines export type) <current

path>: Enter a file name and extension or press ENTER

CUT:

Menu: Edit » Cut Keyboard:CUTCLIP Shortcut key:CTRL+X

Copies selected object to the clipboard and then deletes the object from current file.

Command line prompt: Select entities to cut to the clipboard: Select entities to cut After executing Cut
command, the contents of the clipboard can be pasted into documents or drawing as OLE objects, detail
procedures can reference in PASTECLIP command and PASTESPEC command. But if the object has links
before cutting, the link will not exist after cutting.
COPY:

Menu: Modify » COPY Keyboard: COPY Alias: CO,CP Shortcut key:CTRL+C

Copies object.
PASTE:

Menu: Edit » Paste Keyboard: PASTE Shortcut key: CTRL+V

The system pastes the entities copied to the clipboard into the drawing at the specified insertion point.

Command line prompt:

Insertion point: Specify a point to paste.
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PASTE AS BLOCK:

Menu: Edit » Paste as Block Keyboard: PASTEBLOCK

The system pastes the entities copied to the clipboard into the drawing as a block at the
specified insertion point.

Command line prompt:

Insertion point: Specify a point to paste a block
PAN:
Menu: View » Zoom » Realtime Keyboard:PAN Shortcut key:P

Moves the view in the current viewport.

Entering PAN on the command line displays the following images while the cursor changes to a
hand cursor. You can lock the cursor to the current position relative to the viewport coordinate system
by holding down the pick button on the pointing device.

Press Esc or Enter to exit, or right-click to display shortcut menu...

ZOOM OPTIONS:

Menu: View » Zoom Keyboard:Zoom Shortcut key:Z

Zooms to display the entire drawing in the current viewport. You can up and down scroll to zoom
graphics while pressing SHIFT or CTRL.

Command line prompt:

ZOOM:In/Out/All/Dynamic/Center/Extents/Left/Previous/Right/Window/OBjects/Scale(nX/nXP)/<Realti
me>: Enter a scale factor or an option or press ENTER

In: Zooms in to display the current graphics.

Out: Zooms out to display the current graphics.

All: Zooms to display all the objects in the current viewport. It can display all the objects even if the
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drawing extends outside the grid limits.

Dynamic: Zooms to display the generated portion of the drawing with a view box. We can size and
position the view box. Positioning and sizing the view box pans or zooms to make sure the image inside
the view box. It will display the view box once you use this option. Then drag it to the location you want
and click, it will display the view box that you can zoom in or zoom out. Resize it and press ENTER to
zoom, or click to return to the panning view box.

Center: Displays the drawing defined by a center point and a magnification value. Increases the
magnification as the value of the height is smaller. Decreases the magnification as the value of the

height is larger.

Center of view <current>: Specify a point or press ENTER.

Enter zoom factor (nX/nXP), or view height <current>:Enter a scale value or specify the height or press
ENTER.

Extents:

Zooms to display the drawing extents and displays all the objects as large as possible inside

the viewport. In a 3D view, ZOOM All is equivalent to ZOOM Extents.

Left:

Specifies left-hand corner point and zoom radio or height to observe window.

Lower left corner: Specify a point

Enter zoom factor (nX/nXP), or view height:<current>: Enter a scale value or specify the height or press
ENTER.
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Previous:

Zooms to display the previous viewport. You can restore up to 10 previous views by default.

Right: Specifies a upper right point and zoom ratio or height to observe window.

Upper right corner: specify a point

Enter zoom factor (nX/nXP), or view height: <current>: Enter a scale value or specify the height or press
ENTER.

Window:

Zooms to display the specified rectangular window.

First point: Specify a point 1

Opposite corner: Specify a point 2

Objects: Scales specified objects so as to display them at the center of the drawing area as large as
possible. Select entities to zoom: Select objects to be displayed in maximum size at the center of the
drawing area, press ENTER when finish selecting.

Scale(nX/nXP):

Zooms to display the current drawing at a specified value.
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Realtime: Pans on screen while pressing the pick button, it will zoom to display the current drawing in
the logical extent. Press Esc or Enter to exit, or right-click to display shortcut menu... The cursor will
changes to a magnifying glass with plus(+) signs.

Find and Replace:

This command allows you to find, replace, or select a text and it controls the results of the
search.

To find and replace a text

1. Do one of the following:

 Select Edit > Find and Replace

 Type find and then press Enter.

2. In the find and replace mask you can see these options:

 Find Text String: Indicates the text string to find. Enter a text string including any wild card
characters, or choose one from the list of the six most recently used strings.

 Replace With: Indicates the text string you want to use to replace the found text. Enter a
string or choose one from the list of the most recently used strings.

 Search In: Indicates whether to search the entire drawing or only the current selection. If
something is already selected, Selection is the default value. If nothing is selected, the default
value is Entire Drawing. You can use the Select Objects button to close temporarily the dialog
box and create or modify the selection set. When selection is completed press Enter or right
click to open the dialog box again.
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 Select Objects Button: Closes temporarily the dialog box so that you can select objects in
your drawing. Press ENTER to return to the dialog box. When you select objects, the Search In
field displays Current Selection.

 Options: Displays the Find and Replace Options dialog box, in which you can define the type
of words that you want to find.

 Find: Finds the text that you have entered in the Find Text String field. This option is not
available if you have not entered any text in the Find Text String field. The found text is
displayed in the Context area. Once you have found the first instance of the text, the Find option
becomes Find Next, which you can use to find the next instance.

 Replace: Replaces the found text with the text that you entered in the Replace With field.

 Replace All: Finds all occurrences of the text that you entered in Find Text String and
replaces it with the text in Replace With. The Search In setting controls whether to find and
replace the text in the entire drawing or the text in the current selection. The status area
confirms the replacements and indicates the number of replacements that have been made.

 Select All: Finds and selects all the objects containing instances of the text that you entered
in the Find Text String field. This option is available only when you select objects in a drawing
and the Search In control is set to Selection. When you choose Select All, the dialog box closes
and a message in the command prompt shows the number of objects founded and selected.
Select All does not replace the text.

 Zoom To: Displays the area in a drawing that contains the results of a find or replace search.

EXIT:

The exit command is used for to close the entire cad drawing file window.
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Chapter 4: Draw Commands-2D

LINE:
Draws lines at any length. You can enter x, y, z coordinates of the point to specify start and end

point of 2D or 3D entities. When using LINE command, system will always prompt to enter point, before
pressing ENTER to finish the command, users can specify series of points, but each line is an
independent object.
Menu: Draw -> Line Command: LINE Aliases: L

MLINE:
Creates multiple parallel lines.
Menu: Draw -> Mline Command: MLINE Aliases: DL

DRAW TRACES:

Creates line segments with required width
Menu: Draw -> Draw Traces Command: -trace Aliases: trace
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RAY:
Creates a ray extends infinitely toward the direction you specify.
Menu: Draw -> Ray Command: RAY Command: RAY

CONSTRUCTION LINE:

Creates a construction line which extents infinitely.
Menu: Draw -> Construction Line Command: XLINE Aliases: XL

FREEHAND:

A freehand sketch consists of many straight line segments, created either as individual line
entities or as a polyline. Before you begin creating a freehand sketch, you must set the length, or
increment, of each segment. The smaller the segments, the more accurate your sketch, but segments
that are too small can greatly increase the file size.
Menu: Draw -> Freehand Command: Freehand Aliases: Freehand
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POLYLINE:
With ActCAD, a polyline is a connected sequence of arcs and lines that is treated as a single

entity. You can draw a polyline with any linetype and using a width that either remains constant or
tapers over the length of any segment. When editing a polyline, you can modify the entire polyline or
change individual segments.

Menu: Draw -> polyline Command: polyline Aliases: pl

3D POLYLINE:

Draws a three-dimensional polyline with straight segments. Although the 3D Polyline command
does not have as many options as the Polyline command, you can apply editing changes, such as splining;
with the Edit Polyline command after the three-dimensional polyline is drawn.
Menu: Draw -> 3D polyline Command: 3Dpoly Aliases: 3P
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POLYGON:
Creates a polygon entity. A polygon entity is created based on the polylines.
Menu: Draw -> Polygon Command: POLYGON Aliases:POL

RECTANGLE:
Creates a rectangular polyline entities.
Menu: Draw -> Rectangle Command: RECTANG Aliases: REC

HELIX:
Creates a 2D spiral or 3D spring.
Menu: Draw -> helix Command: helix Aliases: helix
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ARC-VARIOUS OPTIONS:

Draws an arc.
Menu: Draw -> Arc Command:ARC Aliases:A

CIRCLE-VARIOUS OPTIONS:

Draws a circle of any size.
Predicted method of drawing circle is through center point and radius. there are
many other ways to draw circle.
Menu: Draw -> Circle Command: CIRCLE Aliases:C
Selects Multiple option will draw multiple circles with the same setting.
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DONUT:
Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a donut

using one of several methods. The default method is to specify the inside and outside diameters of the
donut, and then specify its center. You can then create multiple copies of the same donut by specifying
different center points until you press Enter to complete the command.
Menu: Draw ->Donut Command: Donut Aliases: do

PLANE:
With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a

solid color. The default method is to specify the corners of the plane. After you specify the first two
corners, the plane is displayed as you specify the remaining corners. Specify corner points in a triangular
manner. The program prompts you for the third point and then the fourth point. If you continue
specifying points, the third- and fourth-point prompts toggle until you press Enter to complete the
command.

Menu: Draw ->Plane Command: plane Aliases: plane or solid

SPLINE:
SPLINE fits a smooth curve to a series of points with the specified tolerance.
Menu: Draw ->Spline Command: Spline Aliases: spl
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ELLIPSE:
Creates an ellipse or an elliptical arc

Menu: Draw ->Ellipse Command: Ellipse Aliases: el

BLOCK-VARIOUS OPTIONS:

You can combine any number of entities into a single block. After you create a block, you can
insert copies of it into a drawing. Each block insertion is treated as a single entity; for example, you can
rotate or scale each block when you insert it. The program adds the name of the new block you insert to
the Block Name list in the ActCAD Explorer.

Menu: Draw ->Block Command: Block Aliases: B

Block Definition Dialog box

Insert block:
Opens a Insert Block dialog box in this you can specify scale of block and location of

block etc..
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Menu: Insert->Block Command: Insert Aliases:

I

POINT-VARIOUS OPTIONS:

Draws point entities.

Menu: Draw->Point->Single point or Multiple points, Command: Point Aliases: po

HATCH:
Fills an enclosed area or selected objects with a hatch pattern or gradient fill.
Menu: Draw ->Hatch Command: BHatch Aliases: H
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To Add patterns:
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GRADIENT HATCH:
Defines the appearance of the gradient fill to be applied.

BOUNDARY:
With the Boundary command, you can designate a specific area of a drawing for operations such

as hatching and dimensioning. You create a boundary polyline by selecting an area inside a closed loop.
The area you select can be bounded by a single closed entity or by multiple entities that intersect

Menu: Draw ->Boundary Command: Bpoly Aliases: Bpoly

From boundary Dialog box click on Add Pick points to define your required boundary.

WIPEOUT:
Wipeouts are created using existing polygons, closed zero-width polylines made up of only line

segments, or new polylines that you draw while using the Wipeout command.
Menu: Draw ->Wipeout Command: Wipeout Aliases: Wipeout
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Revision Cloud:

The revision cloud consists of a series of consecutive arcs of a polyline. It is used to draw
attention to certain parts of a drawing during its revision.

Revising your drawings it is possible to use the Revision cloud command to mark out your
revisions. REVCLOUD creates a polyline of consecutive arcs making up an object in a cloud shape.

It is possible to set arc length values for a revision cloud. REVCLOUD stores the last used arc length.

Menu: Draw -> Revision cloud Command: Revision cloud

Aliases: Revcloud

Revision cloud
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Region:
You can convert a closed entity into a two-dimensional region. After you create a region, you

can modify it using the various three-dimensional tools. For example, you can create a region from a
square, and then extrude the square to create a three-dimensional cube.

Menu: Draw -> Region Command: Region Aliases: Rev

Text :

Single-line Text:
This option is used to create a single-line text entity. Each line of text is a separate entity and

can be rotated, adjusted and resized. To begin another line, press ENTER after entering characters at the
command line. As you type at the command line, the text you are typing is displayed on the screen. By
applying a style to the text, you can use a variety of character patterns or fonts that you can stretch,
compress, make oblique, mirror, or align in a vertical column.
Menu: Draw -> Single line text Command: Single line text Aliases:DT

J

Multi-line Text:
MTEXT creates paragraphs that defines the width of the paragraph and its location in the

drawing to display text you enter.

Menu: Draw -> Text -> Multiline Text Command: TEXT Aliases: MT
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Justification:
Determines both text justification and text flow, for new or selected text, in relation to

the text boundary. The current justification (Top Left, by default) is applied to new text.
You can get more details from the following images.]

Rotation: Specifies a rotation angle for the multiline text entity.

Rotation angle for block of text <current>: Specify a point or enter a angle value or press
ENTER

Style: Specifies the style for the multiline text.

Text style to use (or '?') <current>: Enter a style name or ? to list all available styles or
press ENTER

Height: Specifies the height for the multiline text.

height <current>: Enter a value or press ENTER

Direction: Specifies the direction to create multiline text entity.

Specify drawing direction: Left-to-right/Right-to-left/Top-to-bottom/Bottom-to-
Top/Style<current>: Enter an option or press ENTER

Width: Specifies the height of text box.

Width of text box: Specify a point or enter a value
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Chapter 5 Modify Commands – 2D

PROPERTIES:

You can change the layer, thickness, linetype, color, and linetype scale of one or more entities.
Depending on the type of entity or entities you select, you can also change other properties, such as the
start point and endpoint of lines, the center point and radius of circles, and the vertices of polylines.

The Properties palette is the main tool for viewing and modifying properties of ActCAD objects.
You can enter commands and work in ActCAD while the Properties palette is open. When you select an
object in the drawing area, the Properties palette displays the properties of that object. If you select
multiple objects, the Properties palette displays all the properties they have in common.

Menu: Modify -> Properties Command: Properties Aliases: entprop
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CHANGE:

Changes the location, size, color, elevation, layer, linetype, linetype scale, lineweight, and three-
dimensional thickness of selected entities. When you select a line, you can also change the location of
the endpoints of the line. When you select a circle, you can also change the diameter of the circle. When
you select a text entity, you can also change the insertion point, style, height, rotation angle, and the
text of the entity. This command is especially useful for text entities.

Menu: Modify -> Change Command: change Aliases: Ch

MATCH PROPERTIES:

Menu: Modify ->Match properties Command: Match Properties Aliases: MA

Duplicates properties from one entity onto another. Only the properties are copied, not the entity itself.
The properties copied are color, layer, linetype, thickness, text, dimensioning, and polyline width (if all
segments of the source polyline are the same width).

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

56

CLIP:

Image:

You can clip images so that only a portion of the image is visible in a drawing. The visible
portion can be in the shape of a rectangle or polygon.

Image clipping can be turned on and off. If you turn off clipping for an image, the entire
image is visible provided that the image is on a layer that is on and thawed. The clipping
information is retained however, and you can turn clipping back on at any time.

Menu: Modify -> Clip->Image Command: imageclip Aliases: imageclip

DELETE:

Use to delete the objects from drawing.

Menu: Modify ->Delete Command: Delete Aliases: E

COPY;

You can copy one or more entities, making one copy or multiple copies within the current
drawing. You can also copy entities between drawings.

Menu: Modify ->Copy Command: copy Aliases: CP or CP

Use any of the following methods to copy entities within the current drawing:
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 Create a copy at a location referenced from the original.

 Create a copy aligned parallel to the original.

 Create a copy as a mirror image of the original.

 Create several copies in a rectangular or circular pattern.

MIRROR:

You can create a mirror image of an entity. You mirror the entity about a mirror line, which you
define by specifying two points in a drawing. You can delete or retain the original entities.

Menu: Modify ->Mirror Command: Mirror Aliases: MI
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OFFSET:

You can use the offset feature to copy selected entities and align them parallel to the original
entities at a specified distance. You can make parallel entities using arcs, circles, ellipses, elliptical arcs,
lines, two-dimensional polylines, rays, and infinite lines.

Menu: Modify ->offset Command: offset Aliases: o

ARRAY:

You can copy an entity in a rectangular or polar (circular) pattern, creating an array. For a
rectangular array, you control the number of copies in the array by specifying the number of rows and
columns. You also specify the distance between each row and column. For a polar array, you control the
number of copies that compose the array and whether to rotate the copies.

Menu: Modify ->Array Command: Array Aliases: AR

Types Of Array:

 Rectangular type

 Polar Array

Rectangular Array:
Creates an array of rows and columns of copies of the selected objects.

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

59

Rectangular Array Dialog Box:

Polar Array:
Creates an array by copying the selected objects around a specified center point.

Polar Array Dialog Box:
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Move:

Moves the specified objects to a new place within a specified distance towards a specified
direction.

Menu: Modify ->Move Command: Move Aliases: M

Rotate:

Rotates objects about a specified point The edges of the viewport are still parallel to the borders
of the drawing area when you rotate an object on the viewport.

Menu: Modify ->Rotate Command: Rotate Aliases: RO
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SCALE:

Enlarges or reduces selected objects, keeping the proportions of the object the same after
scaling.

Menu: Modify ->Scale Command: Scale Aliases: SC

STRETCH:

It can changes the size of the object by stretching them in one direction. When you stretch
entities,you must select the entities using either a crossing window or a crossing polygon.You then
specify a displacement distance or select a base point and a displacement point.When we enter the
stretch command in the commandbar it will displays as shown in below.

Menu: Modify ->Stretch Command: Stretch Aliases: S

EDIT LENGTH:

You can change the length of entities or the included angle of arcs. Use any of the following
methods to change the length of an entity:

 Dynamically drag the endpoint or angle.

 Specify an incremental length or angle measured from an endpoint.
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 Specify the new length as a percentage of the total length or angle.

 Specify a new length or included angle.

Menu: Modify ->Edit Length Command: Edit Length Aliases: EditLen

TRIM:

Trims objects to meet the edges of other objects.

Selects objects that define the cutting edges at which you want to trim an object, or press
ENTER to select all objects as potential cutting edges. Valid cutting edge objects include 2D and 3D
polylines, arcs, circles, ellipses, lines, layout viewports, rays, regions, splines, text, and xlines. TRIM
projects the cutting edges and the objects to be trimmed onto the XY plane of the current user
coordinate system (UCS).

Menu: Modify ->Trim Command: Trim Aliases: TR
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EXTEND:

Extends objects to meet the edges of other objects.

Menu: Modify ->Extend Command: Extend Aliases: Ex

BREAK:

Breaks the selected object between two points.

Menu: Modify ->Break Command: Break Aliases: BR

JOIN:

Joins similar objects to form a single, unbroken object.You can join two entities into a single
entity. You can join either two lines or two arcs. The two lines must be parallel; the two arcs must share
the same center point and radius.

Menu: Modify ->JOIN Command: Join Aliases: JOIN
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CHAMFER:

Establishes chamfer on lines which are crossed, radiating or unlimited long. If the objects to be
chamfered do not crossed, the system will automatically trim or extend the object to make the
chamfering possible.

Menu: Modify ->Chamfer Command: Chamfer Aliases: CHA
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FILLET:

FILLET Creates fillets round the edges of two arcs, circles, elliptical arcs, lines, polylines, rays,
splines, or xlines with an arc of a specified radius. FILLET also rounds the edges of 3D solids.

Menu: Modify ->Fillet Command: Fillet Aliases: F

FLATSHOT:

Creates a 2D representation of all 3D objects based on the current view.

The edges of all 3D solids, surfaces, and meshes are projected line-of-sight onto a plane parallel
to the viewing plane. The 2D representations of these edges are inserted as a block on the XY plane of
the UCS. This block can be exploded for additional changes.

Menu: Modify ->Flatshot Command: Flatshot Aliases: Flatshot

EXPLODE:

Breaks a compound object into its component objects.

Explodes a compound object when you want to modify its components separately. Objects that
can be exploded include blocks, polylines, and regions, among others.

Menu: Modify ->Explode Command: Explode Aliases: X
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GROUP:

A group is a collection of entities saved together that you can select and edit as a unit. Groups
allow to easy combine drawing elements that you need to manage as a unit. For example, groups are
useful in associating 3D solids when you do not want to combine them with a Boolean operation.

Menu: Modify ->Group Command: Group Aliases: Group

Group Dialog Box

Creating groups:
When you create a group, you enter a group name and description, and then select the

entities for the group.

To create a group

1. Do one of the following:

 Choose Modify > Group.

 Type group and then press Enter.

 Click the button Groups () and follow number 5
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2. Under Create New Group, enter the name and description of the group.

3. Click Selectable if you want all entities in the group to be selected when you select one
entity of the group in the drawing.

4. Click Select Entities and Create Group.

5. Select the entities for the group, and then press Enter.

6. In the Group dialog box, click OK.

HYPERLINK:

In your ActCAD drawings, you can include hyperlinks, which are pointers that take you to
another location, such as a Web address or a file on a particular computer. You can attach a hyperlink to
any entity in your drawing. Then, when you select that entity, you can open the link and jump to the
specific Web address or file location. You can create absolute hyperlinks, which store the full path to a
file, or relative hyperlinks, which store a partial path relative to a base folder or URL.

To create a hyperlink:
1. Type hyperlink and then press Enter.

2. Select an entity or entities that you would like to associate with a hyperlink; then press Enter to
display the Edit Hyperlink dialog box.

3. Do one of the following:
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 Click Browse to specify a file.

 In the Link to File or URL box, type a Web address.

4. If you wish to use a common path for all hyperlinks in the drawing, check the Use relative path
for hyperlinks box. Relative paths provide flexibility if you move files to a different folder, since
you can change multiple hyperlink paths at once, rather than change them all individually.

5. Click OK to close the Edit Hyperlink dialog box.

Arc Aligned Text:

ActCAD has ARCTEXT command to create and edit curved text in your drawing. You can apply many text
and alignment styles in this dialog. You can double click on existing ARCTEXT and change its parent arc
apart from editing other parameters. A text preview is provided on the dialog to see the text before
actual placement into drawing.
At the Command prompt, enter ARCTEXT or select ArcAligned on the Express Tools tab, Text panel. Select an
existing arc. Enter the text in the ArcAlignedText Workshop – Create dialogbox. Thiscreates a special
ARCALIGNEDTEXT object.o
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Chapter 6: Dimension Commands

QUICK DIMENSION:

To create and modify quickly a series of dimensions you can use the QDIM command. This
command is particularly useful when you create a series of baseline or continued dimensions or when
you dimension a series of circles and arcs.

Menu: Dimension -> Quick Dimension. Command: Quick Dimension

Aliases:Quick Dimension;

LINEAR:
Linear dimensions annotate linear distances or lengths and can be oriented horizontally,

vertically, or aligned parallel to an existing entity or to the selected extension origin points. After you
create a linear dimension, you can add a baseline dimension or a continued dimension. A linear baseline
dimension inserts an additional dimension from a common first extension line origin of a previous linear
dimension. A linear continued dimension continues a linear dimension from the second extension line of
a previous linear dimension.

Menu: Dimension -> Linear. Command: Linear Dimension Aliases: DLI
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ALIGNED DIMENSION :

Menu: Dimension -> Aligned. Command: Aligned Dimension Aliases: AL

COORDINATE DIMENSIONS :

An ordinate dimension annotates the perpendicular distance from an origin or base
Point (the origin of the current user coordinate system [UCS]). Ordinate dimensions
Consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures
Distances along the x-axis; a y-ordinate dimension measures distances along the y-axis.

As you select ordinate points, the program automatically determines whether the
Point is an x- or y-ordinate based on which direction you drag the second point. You Can
Also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimension text
Is always aligned with the ordinate leader lines, regardless of the text orientation specified by the
current dimension style.

Menu: Dimension -> Coordinate Command: Coordinate Dimension Command: DOR
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Leader:

Leaders consist of a line or series of lines that connects a feature in a drawing to an
Annotation. Generally, you place an arrowhead at the first point. An annotation, cre
-ated as dimension text, is placed immediately adjacent to the last point. By default,
the text placed at the end of the leader line consists of the most recent dimension. You
can also type an annotation as a single line of text.

Menu: Dimension -> Leader. Command: Leader Aliases: LE

RADIUS:

Menu: Dimension -> Radius Command: Radius Aliases: DR
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DIAMETER:

Diameter and radius dimensions annotate the radii and diameters of arcs and circles. You can
optionally include centerlines or center marks.

Menu: Dimension -> Diameter Command: Diameter Aliases: DDI

ANGULAR:

Angular dimensions annotate the angle measured between two lines. You can also dimension an
angle by selecting an angle vertex and two endpoints. After you create an angular dimension, you can
add a baseline dimension or a continued dimension. An angular baseline dimension inserts an additional
dimension from a common first extension line origin of a previous angular dimension. An angular
continued dimension continues an angular dimension from the second extension line of a previous
angular.

Menu: Dimension -> Angular. Command: Angular. Aliases: DAN
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ARC LENGTH:

Extension lines of an arc length dimension can be orthogonal or radial. An arc symbol is
displayed either above or preceding the dimension text. Arc length dimensions measure the distance
along an arc or polyline arc segment. The

Menu: Dimension -> Arc Length Command: Arc Length Aliases: Dimarc

BASELINE: Creates a base line dimension from a specified Baseline

Note:Before you can use this procedure, you must first create a dimension

.Menu: Dimension -> Baseline. Command: Dimbaseline. Aliases: DBA
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Continue: Creates

Note:Before you can use this procedure, you must first create a dimension

Menu: Dimension -> Continue. Command: Dimcontinue Aliases: DCO

GEOMETRIC TOLERANCE:

Geometric tolerances indicate the maximum allowable variations in the geometry defined by a
drawing. ActCAD draws geometric tolerances using a feature control frame, which is a rectangle divided
into compartments. Each feature control frame consists of at least two compartments. The first
compartment contains a geometric tolerance symbol that indicates the geometric characteristic to
which the tolerance is applied, such as location, orientation, or form. For example, a form tolerance may
indicate the flatness or roundness of a surface.

Menu: Dimension -> Tolerance Command: Tolerance Aliases: TOL
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CENTER MARK:

The default sizes of the center mark components can be set from the Dimension
Style Manager, Symbols and Arrows tab, Center Marks (DIMCEN system variable).

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

76

You can choose between center marks and centerlines and specify their size when you set up
the dimension style. See DIMSTYLE. You can also change center mark settings using the DIMCEN system
variable.

Menu: Dimension -> Center Mark Command: dimcenter Aliases: dimcenter

MAKE OBLIQUE:

Extension lines are normally created at a perpendicular angle to the dimension line. You can
change the angle of the extension lines, however, so that they tilt relative to the dimension line.

Menu: Dimension ->Make Oblique. Command: Dimedit Aliases: Dimedit

EDIT DIMENSION TEXT:

You can rotate the text of an existing dimension, move the dimension text to a new position, or
replace selected dimension text with new text. You can also restore dimension text to its original
position as defined by the current dimension style.
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When you rotate or replace selected text, you specify the change first, and then select one or more
dimensions to which to apply the change. All the selected dimensions are updated simultaneously.

Rotate Dimension Text:
Menu: Dimension ->Rotate Dimension Text. Command: Rotate Dimension Text.
Aliases: Dimedit

Reposition Dimension Text:

To restore the dimension text to the original position, choose Restore. To change the angle of
the dimension text, choose Angle. To change the left or right orientation of the dimension text, choose
Left or Right.

Menu: Dimension -> Reposition Dimension Text Command: DIMTEDIT Aliases: DIMTEDIT

Restore Text Position:
You can locate dimension text manually and specify its alignment and orientation.

Menu: Dimension -> Restore Dimension Text Command: DIMTEDIT Aliases: DIMTEDIT

SAVE STYLE: It allows you to save your current dimension style as a new dimension style

Menu: Dimension ->Save Style Command: DIMSTYLE Aliases: DIMSTYLE
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RESTORE STYLE: It allows you to restore your dimension style from a group of dimension styles

Menu: Dimension ->Restore Style Command: DIMSTYLE->Restore Aliases: DIMSTYLE

Override: Controls overrides of system variables used in selected dimensions.

Menu: Dimension ->Override.

Chapter 7: Format Commands

LAYERS:-

About Layers and its Applications:

You can use layers to control the visibility of objects and to assign properties to
objects. Layers can be locked to prevent objects from being modified.

You can reduce the visual complexity of a drawing and improve display performance
by controlling how objects are displayed or plotted. For example, you can use layers to
control the properties and visibility of similar objects, such as electrical parts or dimensions.
Also, you can lock a layer to prevent objects on that layer from being accidentally selected
and modified.

Setting current layer:
Layers in ActCAD® are like the transparent overlays you use in manual drafting. You use layers to

organize different types of drawing information. In ActCAD, each entity in a drawing exists on a layer.
When you draw an entity, it is created on the current layer.
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Layer properties manager:
Layers are used to organize and classify the objects of a drawing. You can create and name a

new layer for each homogeneous group of objects (for example walls, dimensions etc.) and then assign
common properties to each layer. The organization of objects into layers allows you to control the
visibility and properties of a large number of entities separately for each layer and it’s useful to make
changes quickly.

Menu: Format -> Layer. Command: Layer. Aliases: LA

Manage layers: ActCAD allows you to manage layers in different ways like lock layer,
Unlock layer, Hide layer

Menu: Format -> Layer. Command: Layer. Aliases: LA

To Lock or Unlock Layer: Select lock or unlock layer option from entity properties tool bar
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Text Styles:

When you add text to a drawing, it uses the current text style. Text style determines the font,
size, angle, orientation, and other characteristics. Every drawing has a default text style, named
Standard, which initially uses the icad.fnt font. You cannot delete the Standard style, but you can
rename it or modifyit. You can change the font, the size of the font, and the oblique angle applied to it.
If you change the font or orientation of an existing style, all existing text entities created using that style
are automatically updatedto reflect the new font or orientation.Changing any other characteristic has no
effect on existing text. You also can create
and use an unlimited number of additional text styles.

Menu: Format -> Text Styles. Command: Text Styles. Aliases:Text Styles.

Point Style:

Menu: Format ->Point Styles. Command: Point Styles.. Aliases:PL.
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Settings: Displays the Point Style dialog box, in which you can specify the style and size for a point.

Multiple: Creates a series of point figures. The system prompts you repeatedly to specify a location
before you enter ENTER:

<Location of point>: Specify a point or enter S

Elevation:

The elevation of an entity is its z-coordinate position in relation to the xy plane in
which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the
xy plane of the current UCS. Positive elevations are above this plane; negative eleva
tionsare below it.

Menu: Format ->Elevation. Command: Elevation. Aliases:ELEV.
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Thickness:
The thickness of an entity is the distance it is extruded above or below its elevation. A Positive

thickness extrudes the entity upward in the positive z direction of the entity; a negative thickness
extrudes it downward in the negative z direction. The thickness is applied uniformly to the entire entity.
You can extrude any two-dimensional entity into a three-dimensional entity by changing the thickness of
the entity to a nonzero Value. For example, a circle becomes a cylinder, a line becomes a three-
dimensional plane, and a rectangle becomes a box.
Menu: Format ->Thickness. Command: Thickness. Aliases:Thickness.

Rename:

Named objects are categories of items such as layers, dimension styles, table styles, text styles,
and so on. It is strongly recommended that you create standard naming conventions for them and save
them in drawing template files.

Menu: Format ->Rename. Command: Rename. Aliases:Rename

Chapter 8.Insert Commands

INSERT BLOCK:

Inserts blocks into current drawing file. In this you can specify

Menu: Insert->Block Command: Insert Aliases: I
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Insert Block Dialog box

BLOCK FROM LIBRARY-VARIOUS STANDARED BLOCKS AVIALABLE:

In the ActCAD Libraries section you find the default blocks already present when you install the
software. These are organized in libraries (eg: Architectural, Electrical, Mechanical ...), categories
(outdoors, indoors, people) and blocks. To insert a block into a drawing you need to select it and press
the Insert icon or, simply, you can drag and drop it into the drawing.
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EXTERNAL REFERENCE:

You can attach another drawing to the current drawing as an external reference and insert a copy
of the drawing into the current drawing. The name of the external reference drawing is added to the
Block Name list. Changes made laterto the referenced drawing will appear in this drawing when you
reload theexternal reference.

Menu: Insert -> External Reference Command: External Reference Aliases: XA, -XR, XATTACH

ExternalReference Dialog box

ATTACH RASTER IMAGE:

When you attach an image to a drawing, the image displays in the drawing but is not saved in
the drawing. The image file remains saved inits original location on your computer, network, or other
media.

If you send or receive drawings that contain images, it is important toinclude with the drawing
all of the image files attached to it. When you open a drawing that contains images, the source image
files must beaccessible for the images to display in the drawing.

Menu: Insert -> Attach raster image Command: Image Aliases: Image
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Attach Raster Image Dialog box

A. Enter a different image file location, if necessary.
B. Choose to place the image automatically in the drawing usingspecifications located in a positioning
file. Enter the TWF file associated with the image or click [...] to select it.
C. Choose to specify the insertion point in the drawing upon insertion, orenter coordinates.
D. Choose to specify the size of the image in the drawing upon insertion or enter the size values.

E. Choose whether to turn clipping display on or off for the image.
F. Choose whether entities located under the image are visible (forimages that support alpha
transparency).
G. Choose to specify rotation in the drawing upon insertion, or enter howmany degrees to rotate the
image to the left.
H. Click to view imageinformation, including color depth and resolution.
I. Choose to save the image path as its full path, relative path to the current drawing folder, or file name
in the current drawing folder.

OLE OBJECTS: (Object linking with embedding)

You can update a linked object automatically every time you open the drawing or you can do so
only when you specify. Anytime a link is updated, changes made to the object in its original file also
appear in the ActCAD drawing, and the changes also appear in the original file if they were made
through ActCAD.
Menu: Insert -> OLE object Command: OLE object Aliases: IO
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DEFINE ATTRIBUTES:

You add an attribute to a drawing by first defining it and then saving it as part of a block
definition. To define an attribute, you specify the characteristics of the attribute, including its name,
prompt, and default value; the location and text format-ting; and optional modes(hidden, fixed, validate,

and predefined).

Menu:Insert-> DefineAttributes command: Define Attributes Aliases: -ATE

Table:

In ActCAD you can create and edit tables very easily. There is a provision to import an external CSV to table
and to export CAD table data to an external CSV file. This table is fully compatible with tables in other CAD
software. You can perform many operations like insert/delete rows, insert/delete columns, merge cells, un-
merge cells etc. You can change cell Background and Text Colors. Apart from these, many controls added to
each cell like lock, unlock, format etc.

A table is a compound object that contains data in rows and columns. It can be created from an empty table
or a table style.
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Chapter 9.View Commands
Redraw:

As you work on a drawing, visual elements may remain after the completion of a command. You
can remove these elements by refreshing, or redrawing, the display.

Menu: View -> Redraw Command: Redraw Aliases: R
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Regen:

Regenerates, or reproduces, the current viewports, and recalculates the screen location of all
entities.

Menu: View -> Regen Command: Regen Aliases: RE

Regen All:

Regenerates, or reproduces, the current viewports, and recalculates the screen location of all
entities.

Menu: View -> Regen All Command: Regen All Aliases: REA

REALTIME OPERATIONS:

3D Orbit:
ActCAD allows you to rotate the visualisation in real time to view your drawing from any angle while in
model space. You cannot rotate the view while in paper space, but also within the layout windows.

If desired, you can continue the rotation of a view after you release the mouse button. Choose
Tools > Options to enable continuous motion.

Menu: View -> 3D Orbit Command: 3D Orbit Aliases: RTROT (Ctrl+Left Mouse Button)
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Real-time x:
Allows you to rotate the view of entities in real time while maintaining the x-axis. You can rotate

the view while in model space, not paper space.

Menu: 3D Orbit -> Real-time x Command: Real-time x Aliases: RTROTX

Real-time Y:
Allows you to rotate the view of entities in real time while maintaining the y-axis. You can rotate

the view while in model space, not paper space.

Menu: 3D Orbit -> Real-time y Command: Real-time y Aliases: RTROTX

Real-time Z:
Allows you to rotate the view of entities in real time while maintaining the z-axis. You can rotate

the view while in model space, not paper space.

Menu: 3D Orbit -> Real-time z Command: Real-time z Aliases: RTROTZ
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View ports:

You can divide a single drawing window into multiple tiled windows (called view-ports) on the
Model tab. You can control the number of windows created and the arrangement of the windows. You
can also save and restore named windowconfigu-rations and display a list of the current and
savedwindow configurations.

1. Creates one or more viewports in the current view.

2. You can create multiple viewports in paper space or model space using VPORTS.

Menu: View -> View ports Command: View ports Aliases: MV

Divides a viewport into two equivalent viewports.

Divides a viewport into three viewports.
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Divides a viewport into the four equivalent viewports.

Named Views:

After you save one or more named views, you can restore any of those view in the current window using
either the view command or the ActCAD Explorer.

Menu: View -> Named views Command: Named views Aliases: v
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3D Views:

To quickly set a view, you can choose one of the predefined3D views. You can select predefined
standard orthographicviews Top, Bottom, Front, Left, Right, and Back or SW(southwest) Isometric, SE
(southeast) Isometric, NE(northeast) Isometric, and NW (northwest) Isometric views.

Menu: View -> 3D views Command: 3D view Aliases: Plan

Orthographic views:

Orthographic views show objects from points of view that areperpendicular to XY, XZ and YZ plans,
obtaining Top, Bottom,Front, Left, Right, and Back views.

Draw a cube and a cylinder as shown in the example:

Top view:
Menu: View -> 3D views Command: Top view

Bottom view:
Menu: View -> 3D views Command: Bottom view
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Left side view:
Menu: View -> 3D views Command: Left side view

Right side view:
Menu: View -> 3D views Command: Right side view

Front side view:
Menu: View -> 3D views Command: Right side view

Back side view:
Menu: View -> 3D views Command: Right side view

Isometric views:
To understand how the isometric views work, look down at the top of a box. If you move toward

the lower-left corner,you are viewing the box from the SW Isometric View. If you move toward the
upper-right corner of the box, you areviewing it from NE Isometric View.
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SW Isometric views:
Menu: View -> 3D views Command: SW Isometric view

SE Isometric views:
Menu: View -> 3D views Command: SE Isometric view

NE Isometric views:

Menu: View -> 3D views Command: NE Isometric view

NW Isometric views:
Menu: View -> 3D views Command: NE Isometric view

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

95

Dynamic View:
Dynamically defines parallel or visual perspective views.Cameras and targets are used to

dynamically view yourthree-dimensional drawing. You can specify the view-ingdirection between the
camera and the target. The centerpoint of the selected enti-ties is considered the target.

Menu: View -> Dynamic View Command: Dynamic View Aliases: Dview

Viewpoint Presents:

To select a preset viewpoint you can also use the PresetViewpoints dialog box that contains
preset views buttonsformerly explained plus isometric views from under-neath the XY plane.

Menu: View -> Viewpoint presets Command: Viewpoint presets Aliases: Setvpoint
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 Click to select a non-axis viewpoint.

 Click to select the previous viewpoint.

 Click to select a viewpoint aligned with an axis.

VISUAL STYLE:

Menu: View -> Visual Style Command: Visual Style Aliases:

SHADE:
You can create a simple shaded picture of the objects displayed in the current viewport. Shading

fills certain objects with a solid color and removes the display of lines that are located behind the
shaded objects. Each object is shaded using its current color.

In any view, you can shade the following types of objects:

Objects with nonzero thickness

Circles

Solid-filled polygons

Wide polylines

Surfaces and 3D solids (when viewing models created in ActCAD)

Menu: Visual Style -> Shade Command: Shade Aliases: Sha

Shaded image

HIDE:
Creates a hidden-line view of your model by removing all the lines that would be hidden behind other
surfaces when seen from your vantage point.

Menu: Visual Style -> Hide Command: Hide Aliases: HI
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WIRE FRAMES:
Wire-frame models, which consist of lines and curves that define the edges of a three-

dimensional entity. You can create a wire-frame model by drawing lines, arcs, polylines, and other two-
dimensional entities anywhere in three-dimensional space. Wire-frame models have no surfaces; they
always appear as outlines. Because you must individually draw and position each entity that makes up a
wire-frame model, creating one can be exacting and time-consuming.
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Chapter 10 Tools

SPELL CHECK:

Corrects the spelling in text objects of a drawing.

It is possible to do the spell checking for any text of a drawing, including:

• Single line text

• Multiline text

• Text in block attributes

• External references

For attributes, only values are checked.

To do the check spelling in another language, you can choose a different dictionary.

You can also customize and manage several dictionaries and switch between them.

To do the check spelling

Do one of the following:

• Choose Tools > Spell Check.

• Type spell and then press Enter.

Menu: Tools-> Spell Check Command: Spell Check Aliases: SP

MAIN DICTIONARY:

The check spelling function allows to choose a main dictionary among many
differ-ent languages. Dictionary files have a .dic extension. To do the check spelling in
another language, you can switch to a different main dic-tionary.

Do one of the following:

• From the Main Dictionary box, select another dictionary in a language that you

need.

• With the Download button you can download a new dictionary.

The download button is linked to a web page that manages a lot of free downloadable

dictionaries in many different languages. Put downloaded dictionaries in the same

folder shown in the Custom Dictionary box.
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DRAW ORDER:

The draw order commands allow you to arrange the images and entities in your
drawing. When multiple entities overlap, you can change the order in which they are dis-

played and printed. You can move entities to the front, back, or on top or below of
another entity.

Menu: Tools-> Draw Order Command: Draw Order Aliases: Draw Order
To reorder entities

1 Do one of the following:

 Choose Image > Draw Order.
 Type draworder and then press Enter.

2 Select the entity you want to reorder, and then press Enter.

The following suggestions may be of help:

 Once placed, you can use the ActCAD 'move' and 'rotate' commands to refine
 your model’s position relative to the image. Do not adjust the position of the

Google Earth’s image. For details, see Chapter 10, “Rearranging entities.”
 Use the Draw Order command to send an image below.
 The image is black and white – a current limitation imposed by Google Earth.

To use Draw Order command

1. Do one of the following:
 Choose Tools > Draw Order.
 On the Tools toolbar, click the Draw Order tool
 Type draw order and then press Enter.

2. Select the entity you want to reorder, and then press Enter.
3. In the prompt box, specify the new drawing order, and then press Enter.
4. If you are reordering above or under, select the entity you want the first entity to

be above or below, and then press Enter.
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INQUIRY:(Distance, Area, List, Id Point, Mass Property, Drawing Status, Time,Status,

Set Variable Calculator)

Distance:

Menu: Tools-> Distance Command: Distance Aliases: Dist
To calculate the distance between two points and their angle

1. Do one of the following:
 Choose Tools > Inquiry > Distance.
 On the Inquiry toolbar, click the Distance tool ( ).
 Type distance and then press Enter.

2. Specify the first point.
3. Specify the second point.

The following type of information is displayed:

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º

Delta X = 11.3878, Delta Y = 6.8418, Delta Z = 0.0000

LIST:

Menu: Tools-> List Command:list Aliases: li

To display information about an entity

Advanced experience level

1. Do one of the following:
 Choose Tools > Inquiry > List.
 On the Inquiry toolbar, click the List tool ( ).
 Type list and then press Enter.

2. Select one or more entities.
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3. Press Enter.
NOTE To return to the drawing window, press F2.

The following type of information is displayed:

DRAWING STATUS:
Menu: Tools-> Drwing status Command:Drawing status Aliases: Drwing status

You can display information about the current status of a drawing, including:

 Drawing name.
 Limits.
 Insertion base point.
 Snap and grid settings.
 Current layer, color, and linetype.
 Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).

To display the drawing status

Advanced experience level

1. Do one of the following:
 Choose Tools > Inquiry > Drawing Status.
 Type status and then press Enter.

The following type of information is displayed:
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TIME:

Menu: Tools-> TIME Command:TIME Aliases: TI

To display the timer information

Advanced experience level

1. Do one of the following:
 Choose Tools > Inquiry > Time Variables.
 Type time and then press Enter.

2. Select any of the prompt box options:
3. Choose Timer On to turn the elapsed timer on.

Choose Timer Off to turn the elapsed timer off.

In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is

displayed:
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PROPERTIES:

The Properties palette can be docked in the drawing area. You can Hide the
palette

And give it a transparency effects.

Menu: Tools-> Properties Command: Properties Aliases: Properties(Ctrl+1)

• Enter a new value.

• Select a value from a list.

• Change the property value in a dialog box.

• Use the Pick Point button to change a coordinate value.
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The properties common to the selected objects are displayed in the Properties palette.

You can then modify the properties of the selected objects in the Properties palette or

you can make other changes to the selected objects by entering an editing command.

To modify the properties from Properties Palette

1 Do one of the following:

• Choose Tools > Properties.

• On the Standard toolbar, click the Properties tool ( ).

• Type properties and then press Enter.

2 Select the entities, and then press Enter.

3 Make changes to the properties you want to change, and then click OK

MACROS :

Each time you start ActCAD, macros areautomatically loaded for the Visual
Basic Application (VBA) CommonProject. If youdo not plan to use VBA, disabling the
macros may improve performance. In addition disabling the macros can enhance security
if you are running ActCAD at a low security level.

Menu: Tools-> Options> macros Command: macros Aliases: macros

To change the options on the General tab

1. Do one of the following:
 Choose Tools > Options.
 Type config and then press Enter.

2. Click the General tab.
3. Under Experience level, select Beginner, Intermediate, or Advanced.
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Loading and running LISP Program:

Menu: Tools->Load LISP Command: Load LISPAliases: appload

Another way you can customize ActCAD is to add custom programs written in anyof several
programming languages that run within ActCAD, including the following:

• LISP

• Visual Basic for Applications (VBA)

• ADS

• DIESEL

In ActCAD, you can run many programs originally created for use with AutoCAD.

Specifically, you can use programs written entirely in AutoLISP with no modification. In
addition, you can run many ADS programs originally written for use with

AutoCAD after first recompiling them using the ActCAD run-time libraries. Many

AutoCAD third-party programs are compatible with ActCAD
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Using LISP routines: ActCAD supports the LISP programming language and is compatible
with AutoLISP, the implementation of the LISP language in AutoCAD. This means that you
can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine
1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

• Drag and drop the LISP file into ActCAD.

2 In the Load Application Files dialog box, click Add File.

3 Select the LISP file that you want to load, and then click Open.

4 Click OK.

A Lists the names of LISP and SDS files already loaded.

B Click to add a LISP or SDS file.

C Click to remove the highlighted file.

D Click to load the highlighted file.

E Click to unload the highlighted file.

F Select to save the current list to the icadload.dfs

file when you click Load, Unload, or OK.
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To run a LISP routine
1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run (make sure
that it is the only one selected), and then click Load.Some LISP routines are created in
such a way that you can run them by simply typing the name of the routine, or by typing a
keyword, directly in the command bar. If noth-ing happens when you attempt to run the
LISP routine from within the Load Application Files dialog box, turn on the display of the
command bar or Prompt History window by choosing View > Command Bar or View >
Prompt History Window, and look for an entry that is similar to the following: Loading
D:\path\routine.lspC:KEYWORD

Drawing Settings

With ActCAD, you typically draw at full-size (1:1 scale), and then set a scale factor when you
print or plot your drawing. Before you begin drawing, however, you need to determine the
relationship between drawing units and real-world units.

Menu: Tools > Drawing Settings Command: Drawing Settings Aliases: SE

To set the angular drawing units

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Drawing Units tab.
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A Determines the type of units you are controlling.

B Select the type of angular units.

C Choose the display precision for angular units.

D Select the direction in which angles increase.

E Select the angle base, the direction of the zero angle.

ActCAD OPTIONS:

You can specify locations for various file types such as those used for drawings, fonts, and
menus in the Options dialog box on the Paths/Files tab. You can even specify multiple paths
for the same file type. In addition, you can change the names of the default system files that
are used for functions such as font mapping and error logging.

Menu: Tools >Options Command: Options Aliases: pr
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A Click to enable AutoSave feature.

B Select the default file format that displays when saving drawings using the
Save As dialog box.

C Click to disable VBA CommonProject macros on startup. (Available if supported
by your version of ActCAD.)

D Select to check all drawings for errors when using the Open command, and
attempt recovery, as needed.

E Select to hide warning messages when opening drawings, if the check box Open
Drawings using Recover is marked.

F Select to check New Drawing Wizard.

G Select to check PPan Accelleration.

H Select to check AutoRedraw after commands.

I Type the file extension for AutoSaved files.

J Enter frequency of AutoSave in minutes.

K Select the experience level.

L Select to enable Content menu on right click.
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M Select to enable the context menu if no entities

are selected.

N Select to enable the quick dragging.

O Select to enable the semplification of the text

during the realtime commands.

P Select to hide the hatching during the realtime

commands.

Q Select to enable VBA Events.

IN-PLACE BLOCK EDITIn the previous ActCAD versions to modify and therefore replace all the
occurrences inserted in a block drawing, it was needed to explode it, make the changes, and
make it up again with the same name to redefine it.

Menu: Tools > In-place block edit Command: In-place block edit Aliases: REFedit

To remove the object from a block

1 Do one of the following:

• Choose Tools > In-place Block Edit > Edit Reference and then select the block.

• Double click on the block to modify.

• Type refedit and press Enter key, then select the block.

DATA EXTRACTION:

You can extract information from the blocks with attributes in the currentdrawing.

The information is used to create a data extraction table saved in an external file

Menu: Tools > Data extraction Command: Data extraction Aliases: Data extraction
1 Do one of the following:

• Select Tools > Data Extraction…

• Type EATTEXT and then press Enter.
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2 The data extraction process starts with the Drawing and template selection dialog

box.

No Template: creates a new data extraction.

Use Template: uses the settings previously saved in an attribute extraction

UCS(USER COORDINATE SYSTEMS)

When working in three-dimensional space, you can define a UCS with its own 0,0,0

origin and orientation separate from the WCS. You can create as many user coordi-

nate systems as you want, and then save and recall them as you need them to simplify

construction of three-dimensional entities.

Menu: Tools > ucs Command: ucs Aliases: ucs

Usc:1.World UCS2. 2.UCS previous3.Face UCS 4.Object UCS 5.Origin UCS

6.View UCS 7.Rotate UCS about X-axis, Y-axis, Z-axis 8.UCS icon settings

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

112

Under Select UCS, click the button corresponding to the UCS you want as the new

current UCS..

A Specify whether to define the new UCS relative

to the current UCS or to the World Coordinate

System (WCS).
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B Select to change the display to the plan view of

the new UCS.

C Click to select the previous UCS.

D Click one of these buttons to select the view you

want of a preset UCS.

E Click to select the WCS.

F Click to align the UCS with the current view.

G Click to display the ActCAD Explorer.

Chapter 11 : Isometric Drawings

Isometric views

To understand how the isometric views work, look down at the top of a box. If youmove
toward the lower-left corner, you are viewing the box from the SW Isometric View. If you
move toward the upper-right corner of the box, you are viewing it from NE Isometric View.

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified
viewpoint.When the snap angle is set to 0, the axes of the isometric plane are 30 degrees, 90
degrees and 150 degrees.With Isometric Snap on, you can work on any of three isometric
planes, each with a pair of associated axes.

 Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap
and grips align along the 90- and 150-degree axes.

 Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap

and grips align along the 30- and 150-degrees axes.

 Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap
and grips align along the 90- and 30-degrees axes.

Set isometric snap and Grid:
You can use the Isometric Snap And Grid option to create two-dimensional isometric drawings.
With the isometric option, you are simply drawing a simulated three-dimensional view on a
two-dimensional plane, much the same as you might draw on a piece of paper. Do not confuse
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isometric drawings with three-dimensional drawings. You create three-imensional drawings in
three-dimensional space.

settings:

Setting a reference grid
A reference grid displays as a pattern of regularly spaced lines. You can turn the display on
and off, and you can specify how far apart the lines are spaced and their color.

The reference grid extends even over the limits of the drawing, helping you to visualize the
boundary of your drawing and to align entities and visualize distances between entities. You
can turn the grid on and off as needed. You can also change the spacing of the grid at any
time.

Setting snap spacing:
Another way to ensure drawing accuracy is to turn on and set snap spacing. When

snap is turned on, the program restricts the selection points to predetermined snap

intervals. Although it is often helpful to match the grid spacing to the snap spacing or

another related setting, the settings do not have to match.

A: Click the check box to enable orthogonal mode.
B: Click the check box to display the reference grid.
C: Specify the x and y grid spacing.
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D: Click the check box to enable snap mode.
E: Specify the x and y snap spacing.
F: Click the check box to use an isometric snap and grid and the isometric plane
G: Specify where display the grid
H: Click the check box to display the grid over the limits
I: Click the check box to display the grid according to the zoom in
J: Click the check box to display the grid according to the zoom out
K: Specify the grid rotation angle.
L: Indicates the current grid rotation angle. M Specify the x- and y-coordinates of origin.
N: Click to match the grid spacing to the snap spacing.

Change the crosshair:
In the Options dialog box, on the Crosshairs tab, you can control how the crosshairs

display. To help you differentiate the x-, y-, and z-axes, a different color is assigned to each.
You can change the default axes colors to any color you want. In addition, you can specify the
size of the crosshairs display, enable grips attraction for the cursor, and you can elect to use
crosshairs as the default pointer shape.

To turn the Isometric Snap And Grid option on

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Snap And Grid.

4 Click the Isometric Snap And Grid check box.

5 Under Isometric Crosshairs, click the option for the isometric plane you want

(Top, Left, or Right).

6 Click OK.
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Draw Isometric Circles:

You can create an isometric circle on the current isometric plane using Ellipse Isocircle.
The Isocircle option is available only when the Isometric Snap is on

OBLIQUE DIMENSIONS :

Extension lines are normally created at a perpendicular angle to the dimension line. You can
change the angle of the extension lines, however, so that they tilt relative to the dimension
line.

1 Do one of the following:

• Choose Dimension > Make Oblique.

• On the Dimension toolbar, click the Dimension Edit tool ( ) and then in the prompt box.

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines.

2 Select the linear dimension, and then press Enter.

3 Type the obliquing angle, and then press Enter.
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Chapter 12 Layout, Viewports and Plotting

UNDERSTANDING LAYOUTS

When you create a drawing, you do most of your work on the Model tab. Each drawing
that you create can contain numerous layouts that simulate the paper on which you
will print a copy of the drawing. Each of these layouts is created on a Layout tab.

LAYOUT:

You can prepare a separate layout for each way you want to print your drawing. The
layout allows you to organize different views to control which portion of your
drawing prints and at what scale.

Menu: Insert -> Layout Command: LAYOUT

To Rename ->

To Delete ->

To Template ->
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Select Existing Layout/Press ok

Selecting a printer or plotter:

You can specify a printer or plotter to be used when printing any drawing. You can print your drawing on
any printer or plotter that is compatible with Windows, including raster printers.

Menu: File -> Print Setup Command: PRINT

1) From the Printer list, select a printer or plotter.

2) Do one of the following:
Choose File > Plot.

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

119

• On the Standard toolbar, click the Plot tool ( ).
• Type print and then press Enter.

3) Click the Scale/View tab.

4) To scale the drawing to fit on one printed page, in Print Scale, select Scale to Fit

5) Select Save Changes to Layout, and then click Apply to save your changes.

SETTING THE SCALE AND VIEW

You can print or plot the entire drawing or a selected portion, depending on which
options you select in the Print dialog box. You can choose to print what is visible on
the screen, or you can specify to print an area of the drawing.
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Edit Hatch:

1) To edit the hatch, select the hatch content by double clicking on it & then Boundary objects window
opens for edit.

2) Select the content to edit as shown below and press ok.
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Edit polyline:

You can edit entire polylines and individual segments using the Edit Polyline tool in the Modify >
Object menu. You can convert polylines into arc and line entities using the Explode tool ( ) on the Modify
toolbar. You can control whether wide polylines are shown filled or as outlines using the Fill tool in the
Format menu

Menu: Modify ->Object -> Edit polyline Command: pedit
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VIEW PORTS IN LAYOUT:

Create at least one layout viewport on the Layout tab. Use each viewport to
help control which portion of the drawing prints and at what scale.

Menu-> view-> viewports Command: viewports
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FILE IMPORTS:

Importing DXF, DWF, and DWT files is similar to opening a standard drawing file.

Menu-> File-> open Command-> OPEN

2) Choose the folder that contains the drawing.

3) In Files of Type, choose the type of drawing you want to import.

4) Choose the file you want to open.
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IMPORTING AN ACIS FILE:

An ACIS file contains three-dimensional solids, regions, or bodies that are saved as
an ASCII .sat file.
Menu-> File-> Acis In Command-> ACISIN

2 Choose the directory containing the SAT file.
3 Choose the SAT file you want to open.
4 Click Open.

EXPORT:

You can save or export ActCAD drawings in a number of different formats for use
with other programs. When you save a drawing in a different format, the program
saves all the entities in the drawing to the new file. Or, you can choose which entities
are included in the new file.
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Menu-> File-> Export Command-> EXPORT

2) Choose the file format.

3) Specify the name of the file you want to create.

4) Click Save.
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Chapter 13 Draw Commands – 3D

Wedge:

You can create three-dimensional wedges consisting of five surface planes. The base
of the wedge is always parallel with the xy plane of the current UCS with the sloped
face opposite the first corner.

Menu-> Draw-> 3d Entities->Wedge Command-> AI_WEDGE
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PYRAMID:

You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by
two points. The base of the pyramid is always parallel with the xy plane of the current UCS.
You position the pyramid by specifying a corner of the base.

Menu-> Draw-> 3d Entities->Pyramid Command-> AI_PYRAMID

BOX:

You can create rectangular boxes, or cubes. A box consists of six rectangular surface
planes. The base of the box is always parallel with the xy plane of the current UCS.
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Menu-> Draw-> 3d Entities->Box Command-> AI_BOX

CONE:

You can create three-dimensional cones defined by a circular base and tapering to a
point perpendicular to the base. The base of the cone is always parallel with the xy
plane of the current UCS.

Menu-> Draw-> 3d Entities->Box Command-> AI_BOX

CYLINDER:

You can create cylinders defined by a circular base. The base of a cylinder is always
parallel with the xy plane of the current UCS; the height of a cylinder is always paral-lel with
the z-axis.

Menu-> Draw-> 3d Entities->Cylinder Command-> AI_CYLINDER
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SPHERE:

You can create spheres. The latitude lines of a sphere are always parallel with the xy
plane of the current UCS; the central axis is always parallel with the z-axis. You posi-tion a
sphere by specifying its center point.

Menu-> Draw-> 3d Entities->Sphere Command-> AI_SPHERE

DISH:

You can create a three-dimensional dish. The latitude lines of a dish are always paral-lel with
the xy plane of the current UCS; the central axis is always parallel with the z-axis.

Menu-> Draw-> 3d Entities->Sphere Command-> AI_DISH
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DOME:

You can create a three-dimensional dome. The latitude lines of a dome are always
parallel with the xy plane of the current UCS; the central axis is always parallel with
the z-axis.
Menu-> Draw-> 3d Entities->Dome Command->

AI_DOME

TORUS:

You can create a three-dimensional donut or ring-shaped entity known as a torus. The
diameter of a ring is always parallel with the xy plane of the current UCS. A torus is
constructed by revolving a circle about a line drawn in the plane of the circle and par-allel
with the z-axis of the current UCS.

Menu-> Draw-> 3d Entities->TORUS Command-> AI_TORUS
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REVOLVE:

You can create three-dimensional solids by revolving closed objects, such as
polylines, polygons, circles, ellipses, and regions. You can revolve the object about a
defined axis, line, polyline, or two points

Menu-> Draw-> 3d Entities->Revolve Command-> REVOLVE Aliases: REV

EXTRUDE:

You can create three-dimensional solids by extruding closed objects, such as
polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can
extrude the object along a selected path, or you can specify its height and taper angle
Menu-> Draw-> 3d Entities->EXTRUDE Command-> EXTRUDE Aliases: EXT

Slice:

You can section or slice a three-dimensional solid, region, or body (typically a sheet).
When you section a solid, you obtain an “inside view” by creating a cross-section
through the solid as a region or block. When you section a region or body, the result-ing
intersections are curves.
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Menu: Draw » Solids » Slice Command:SLICE Aliases:SL

Section:

When you section a solid, you obtain an “inside view” by creating a cross-section
through the solid as a region or block. When you section a region or body, the resulting intersections are
curves

Menu: Draw » Solids » Section Command:SECTION Aliases:SEC
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INTERFERE:

Creates a composite 3D solid from the common volume of two or more solids.

Menu: Draw » Solids » Interference Command: interfere Aliases:INF

MESH:

You can create a surface called a Coons surface patch, a mesh connecting four edges.
You select the entities that define the edges. Edge entities can be arcs, lines, or
polylines. The four edge entities must form a closed loop and share endpoints. A
patch is a bicubic surface (one curve extends in the M-direction and the other in the
N-direction) interpolated between the four adjoining edges. You can select the edges
in any order. The first edge you select determines the M-direction of the mesh

Menu: Draw » Surface »Mesh Command: Aliases:
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2D SOLIDS:

The SOLID command creates 2D filled polygons. The first two points define one edge of the
polygon. The third point is diagonally opposite the second point and the fourth point is diagonally
opposite the first point.
Menu: Draw » Surface »2d solid Command: Solid Aliases:

3D SURFACE:

You can create rectangular boxes, or cubes. A box consists of six rectangular surface
planes. The base of the box is always parallel with the xy plane of the current UCS.
You position the box by specifying either a corner or the center of the box. You deter-mine
the size of the box by either specifying a second corner and the height; defining
the box to be a cube and then providing its length; or specifying the length, width, and
height.

Menu: Draw » Surface »3D Surface Command: Aliases:

Revolved Surface:
You can create a surface of revolution, which is a three-dimensional body that approximates the

surface generated by rotating a two-dimensional profile around an axis. You select the two entities that
define the profile and the axis. You also specify the starting angle and the number of degrees to revolve
the profile.

Menu: Draw » Surface »Revolved Surface Command: revsurf Aliases: revsurf
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Tabulated Surface:
You can create an extruded surface, which is a three-dimensional body that approximates the

surface generated by extruding a path curve along a direction vector. You select the two entities that
define the path curve and direction vector. The length of the direction vector determines the distance
the path curve is moved along the direction vector. The extruded entity can be an arc, circle, line, or
polyline. You can choose a line or open polyline as the direction vector. The resulting body consists of a
series of parallel polygonal planes running along the specified path.

Menu: Draw » Surface »Tabulated Surface Command: tabsurf Aliases: tabsurf

Ruled Surface:
You can create a ruled surface, which is a three-dimensional body that approximates the surface

between two existing entities. You select the two entities that define the ruled surface. These entities
can be arcs, circles, lines, points, or polylines.

Menu: Draw » Surface »Ruled Surface Command: rulesurf Aliases: rulesurf

Edge Surface:
Creates a three-dimensional mesh with vertices averaged between four edges. You can apply this
command to any four adjoining edges. The edges can be lines, arcs, or open two-dimensional or three-
dimensional polylines, but all edges must be touching to form a closed, rectangular entity. You can use
the SURFTAB2 system variable to define the N-direction mesh density of the coons surface.

Menu: Draw » Surface »Edge Surface Command: edgesurf Aliases: edgesurf
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Chapter 14 – Modify Commands - 3D

3D Operations :

Rotate 3D :
You can rotate selected entities about a specified axis in three-dimensional space.

Menu: Modify 3D Operation Rotate 3D Command: Rotate3D Aliases: Rotate3D

Align :

Aligning one object with an other object by specifying 3 source points and 3 destination points.

Menu: Modify 3D Operation Align Command: align Aliases: align
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Mirror 3D :
Creates a mirrored copy of selected objects across a mirroring plane.

Menu: Modify 3D OperationMirror3d Command: Mirror3d Aliases: Mirror3d

3D Array :
Creates a 3D matrix of objects in a rectangular or polar arrangement.

Menu: Modify 3D Operation 3D Array Command: 3darray Aliases: 3darray

Polar Array:Copies objects about an axis of rotation.
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Rectangular Array :Copies objects in a matrix of rows (X axis), columns (Y axis), and levels (Z axis).
An array must have at least two rows or two columns or two levels.

Interfere :
Creates a temporary 3D solid from the interferences between two sets of selected 3D solids.

Menu: Modify 3D Operation Interfere Command: Interfere Aliases: Inf

Slice :

Slices the selected solid and retains either halves of the sliced solid or the portion you specified. The
sliced solid retains the layer and color properties of the original solids.

Menu: Modify 3D Operation Slice Command: Slice Aliases: sl

1st Set2nd Set
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Solids Editing :

Union :
Combines selected 3D solids, surfaces, or 2D regions by addition.

Menu: Modify Solid Editing Union Command: union Aliases: uni

Subtract :

Combines selected 3D solids, surfaces, or 2D regions by subtraction. With SUBTRACT, you can create a
3D solid or surface by subtracting one set of existing 3D solids from another, overlapping set.

Menu: Modify Solid Editing Subtract Command: subtract Aliases: su

1st Set
2nd Set
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Intersect :

Creates a 3D solid, surface, or 2D region from overlapping solids, surfaces, or regions.

Menu: Modify Solid Editing Intersect Command: intersect Aliases: in

Imprint :

Imprints 2D geometry on a 3D solid or surface, creating additional edges on planar faces. Imprinting is
limited to the following objects: arcs, circles, lines, 2D and 3D polylines, ellipses, splines, regions, bodies,
and 3D solids.

Menu: Modify Solid Editing Imprint Command: solidedit

1st Set

2nd Set

1st Set , Press Enter

2nd Set, Press Enter

Enter y (Yes) to remove it. Enter n (No) to retain it.

1
2
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Colour Edges :

Colour a set of edges for a 3d-solid or surfaces.

Menu: Modify Solid Editing colouredges Command: solidedit

f edges from a 3d solid or from surfaces.

Extrude Faces :

Extends the dimensions of a 2D object or 3D face into 3D space. In most cases, if you extrude a closed
object, the result is a new 3D solid. If you extrude an open object, the result is a surface.

Menu: Modify Solid Editing extrude faces Command: extrude Aliases : ext
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Move Faces :

Move the face of 3D solid to a specified distance.

Menu: Modify Solid Editingmove face Command: solidedit

Offset Face :

Offsets faces by a specified distance.
Menu: Modify Solid Editing offset face Command: solidedit
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Delete Face :

Deletes the selected faces.
Menu: Modify Solid Editing delete face Command: solidedit

Rotate Faces :

Rotate the selected faces about the specified axis.

Menu: Modify Solid Editing rotate face Command: solidedit
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Taper faces :

Tapers faces with an angle. The rotation of the taper angle is determined by the selection
sequence of the base point and second point along the selected vector.

Menu: Modify Solid Editing taper face Command: solidedit

Colour Faces :

Colour the set of faces for a 3D solid.

Menu: Modify Solid Editing colour face Command: solidedit

Copy Faces :

Copies the selected faces to a specified placement. Copy faces as a region or a body. The direction that
you move the region is from the base point to the end point.

Menu: Modify Solid Editing copy face Command: solidedit

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

145

Clean :

Removes shared edges or vertices that have the same surface or curve definition on either side of the
edge or vertex.

Menu: Modify Solid Editing Clean Command: solidedit

Shell:

Shelling creates a hollow, thin wall with a specified thickness. You can specify
a constant wall thickness for all the faces. You can also exclude faces from the shell
by selecting them. A 3D solid can have only one shell. The system creates new faces
by offsetting existing ones outside their original positions.

Menu: Modify Solid Editing Shell Command: solidedit
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Separate:

Separates 3D solid entities with disjointed volumes into independent 3D solid
entities

Menu: Modify Solid Editing Separate Command: solidedit

Check:

Validates the 3D solid object as a valid Shape Manager solid.
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Chapter 15: Rendering

RENDER:

A visualization technique in which all surfaces of a model are shaded as though they were
illuminated from an imaginary light source located behind you as you face the screen. Rendered images
are photo-realistic, having depth, shadow, reflection, and texture.

Rendered object

Full rendering creates a photo-realistic image of your model, complete with light sources,
shadows, surface material properties, and reflections. You can illuminate your image with spotlights,
distant lighting to simulate sunshine, and ambient light. If you choose not to customize the light sources,
the program generates default light sources for you.

Loading Render Toolbar: Right click any tool bar you will get Toolbar list from that list
select the render toolbar

Render toolbar options:

Hide: Creating a hidden-line view of your drawing removes all the lines that are hidden behind
other surfaces when seen from your vantage point. When you remove hidden lines or shade a model,
the program treats the entities differently, depending on how you created them. Wire-frame models
always appear transparent, because they have no surfaces. Surface models appear filled, with surfaces
applied to all visible sides.
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Shade: Creating a shaded image of your drawing removes hidden lines and then applies
shading to the visible surfaces based on their entity color. Because they are intended to provide a quick
visualization, shaded images do not have a light source and use continuous colors across surfaces,
causing them to appear flat and unrealistic.

Shaded Objects

Render:

Menu: View -> Render -> Render Command: RENDER Aliases :RR

Example of a rendered image

Full Render:
Menu: View -> Render ->Full Render Command: Full Render Aliases :RR

Example of a rendered image
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Render preferences: The Render Preferences command allows you to control several aspects of
the rendering system and the Render Settings dialog box is divided into five different worksheets
entitled: Rendering, Shadows, Floor, Site, and Render to File.

Menu: View -> Render ->Preferences

Command: Render Preferences

Aliases:-SETRENDER

The Rendering worksheet is shown below and is followed by a table listing each of the available controls
and their function.

MATERIALS:

Using materials for rendering bestows the rendered entity with strong realistic and stereoscopic sense.

Several materials are provided with editable properties such as pattern type, color map and surface
finish which decide how the material will be mapped to the surface of the entity in material library. If
you have specified light to illuminate the entity, the material of the entity surface reflects the light
clearly and generates shadows according to its own property, setting the materials and lighting
properties together, you can get real visual effects of rendering. Thus you are required to make
comprehensive modification for lighting, materials and backgrounds to obtain the expected visual
effects.

Menu: View ->Render -> Materials Command: MATERIALS Alias: RMAT
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Material Assignment Dialog Box

In this dialog box you can apply and create new materials to your selected objects

ADDING SHADOWS: The Shadows worksheet appears on the Render Settings Dialog box and is
used to control some of the aspects of the shadow computations in the rendering module.

Menu: View -> Render ->Preferences ->Shadows

BACKGROUND SETTING:
The Background Properties window allows you to specify the background or backdrop for your

image. It is essentially identical to the Material Assignment window except that it applies to the
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background instead of surfaces in the drawing. The background is an infinite plane behind the rest of
your drawing. A variety of background options are available as described below. By default, no
background is used and the background will appear black. Note that the background is an infinite,
planar surface and will reflect off of any reflective surfaces in your model. The background is not
affected by lighting however, so no shadows or highlights will be seen on the background.

Menu: View -> Render ->Background Command:Background

CUSTOMIZING MATERIAL: In ActCAD you can customize the material properties like color,
transparency by using material editor dialog box which is available in material Assignment dialog box.

APPLYING LIGHTS:

Toolbar: Render ->Lights Menu: View -> Render -> Light Command: LIGHT
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The Lighting command activates the Lighting dialog box which allows you to specify how your drawing or
scene is lit. You can control placement of the lights, light color, and light intensity. The Lighting dialog
box, illustrated below, includes four buttons in the upper left corner of the window that allow you to
select a preset lighting configuration. To the right of those buttons is a list of all of the lights currently
defined in the drawing and buttons that allow you to add or delete from the list of lights. The change
the characteristics of a particular light in the drawing, you first click on the name of the light in the light
list. In the upper right corner of the window, the name of the selected light will be shown, as well as the
color of the light and the light type.

Types of lights:

 Ambient light
 Point light
 Distant light
Ambient:

An ambient light illuminates the entire scene evenly and does not cast shadows or
change with viewing angle. The parameters available for an ambient light are the light color
and the light intensity. Ambient light can be used to fill in dark or shadowed areas of a
drawing. It can also be used to make certain objects in a scene appear to glow. Note that too
much ambient light will make the scene flat and lifeless since it flattens the shadows and
highlights that provide depth cues.
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Point:

A point light represents light emanating from a specific point in (or out of) the drawing
scene. Several additional parameters are available for the point light including its position, and its
diameter. The diameter controls the size of the light source and hence the sharpness of the
shadows cast by the light. A true point light source would have a diameter of zero and casts sharp-
edged shadows. A larger diameter makes the light source into an area light source that will cast
softer-edged shadows. Note that soft-edged shadows require additional rendering time

Distance:

A Distant light represents a light that is a large distance away from the surfaces in the drawing (e.g. the
sun). All of the light rays are essentially parallel to each other so the shadows cast by the light have
sharp edges. This option allows you to use a Sun Position Calculator that will calculate the position of
the sun at any time of the day or year at any point on the earth's surface. With this type of light, the
light's position is always calculated in the drawing's World Coordinate System. The Azimuth angle
measures the compass bearing in the X-Y plane to the light and the Elevation angle measures the angle
of the light relative to the X-Y plane horizon. By default, an azimuth angle of 0 degrees is in the +Y
direction. However, this can be altered by adjusting the Site Orientation parameter on the Site Location
tab of the Render Settings dialog.
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Chapter 16: Addons

ActCAD Converter:

ActCAD Drawings Converter works outside ActCAD to convert a bunch of dwg/dxf/dgn files from one
format to another. This converter support all file versions from R2 to 2018. This conversion process is
much faster compared to above tool and offers many additional functions.

It has an ActCAD converter that can convert DWG files to DXF or DGN file format in the add-ons tabs.
You can either choose a single file or a number of files for conversion, after selecting you can select the
location for storing the converted file format. Thus the required file format can be used according to the

need. ActCAD supports DGN, DWG, DXF file formats. It can open DGN file and save them as DWG or

DWG file

.

Open PDF to Edit

In ActCAD, you can open any existing vector PDF file directly and edit the entities just like a normal CAD
drawing. All you have to do is to select the PDF file and click OK. ActCAD will convert the file to DXF at
same location of original pdf and with same name. It will launch the converted drawing to ActCAD and
fit it to graphics window. After that you can save the drawing to any of the supported dwg or dxf or any
other file formats.

Steps to convert PDF to DWG
1. Ribbon --> Addon --> OPen PDF to Edit.
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2. Select the PDF file to be convert to DWG

3. After selecting the PDF file click on OPEN it will be converted to dwg.

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

156

Raster to Vector

You will probably be able to load a raster file (like BMP, TIFF, PCX -file) into your CAD program -
nowadays most CAD programs can import and display raster files. However, once you have imported a
raster file into your CAD program you will find that all you can do is look at it or trace over it. You cannot
change or edit it.
This is because CAD programs can only work with vector files. If you want to edit a raster file in your CAD
program you must first convert it to a vector file. You do this using raster to vector conversion software.
Once you have converted the raster file to vector you will be able to import it into your CAD program
and edit it just like any other drawing you have created using your CAD program.
The list below summarises the process of converting a paper drawing to a CAD drawing using a raster to
vector converter:
1. Create a raster file by scanning the paper drawing into RasterVect using a scanner.
2. Use RasterVect to convert the raster file into a vector file.
3. Import the vector file into your CAD program.
4. Edit the drawing in your CAD program.
RasterVect saves many hours of tedious work.

Process :

Select a file to convert Raster to vector and Click on OPEN
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Unit Converter

While working on design projects, you may have to convert some engineering units frequently. ActCAD
has a ready tool inside add-on menu for easy unit conversions for all common engineering units.

Audit Drawings

ActCAD has a special tool to audit & fix any internal errors in your dwg/dxf files in batch mode. Select
the location of input folder and start the process. ActCAD will open each drawing and do database audit
and automatically fix any internal errors and save the drawing to output folder. The process will repeat
in a loop to avoid all manual operations during the conversion process. Just relax and observe the
conversion process.

Your DWG file contains a database of all the information within your drawing. As you work on your
drawing this database is constantly updated by adding new information and deleting old information.

Due to all this editing, errors can occur and need fixing before the DWG becomes corrupt and issues
start appearing. In extreme cases you may find that your DWG won’t open at all, if this is the case then
you need to “recover” your drawing

https://actcad.com


Copyright© 2018 ActCAD LLC, USA https://actcad.com support@actcad.com

159

Extract Block Attributes

This is another useful utility in ActCAD to extract all Block Attributes to an external Excel file with one
button click. No need to select any complex templates and remember the syntax like regular data
extraction tool. The attributes as in attributes editor will be copied to excel file in same sequence for
ready use in other applications like SAP, BOM tables etc.
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Import CSV Points

Many times users have point cloud data stored in Excel/csv files. ActCAD has a provision to directly import all
these points with one button click as geometric points to working drawing at correct 3D locations. You may
have to adjust your point styles option to view the imported points inside your graphics window.

Capture CAD points to CSV

This program is just opposite to above tool. You can click a series of points inside your drawing (like hole
coordinates, road levels, block locations etc.) and their coordinates will be captured to external csv file. You
can continue the selections as long as you need and program will continue to capture the points. In order to
correlate the points data, ActCAD will add a serial number to each point inside the drawing and same
numbers will be maintained in csv file.
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Change Numeric Text Values

Sometimes in drawings, you may have to modify a series of number text with some modifications like
addition, subtraction, multiplication, division etc. Manually editing each text will take lot of time. ActCAD has
an in-built program to modify your texts in drawing in batch mode. You can set the operation and parameter
before starting the change. This feature not only save your time but increase the accuracy and eliminate any
human errors.

P & ID Label Text Creator

ActCAD has a tool to create P&ID label text in standard format by asking few values from the user. You
can orient the text at any angle as per pipe lines with few clicks.
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LH Sections

LH Sections is an additional and helpful tool for Civil Engineers and Surveyors who are having
coordinates of the Land Surface and want to execute them in CAD Software as L Sections or H Sections.
LH Sections feature in ActCAD needs your CSV File with coordinate inputs to access and draw the Section
Profile accordingly. The user can configure its CSV Data with the user friendly interface.

https://actcad.com
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